Verizon - iPhone won't connect to 3G data

Discussion in 'iPhone Tips, Help and Troubleshooting' started by DDustiNN, Mar 9, 2011.

  1. DDustiNN macrumors 68000


    Jan 27, 2011
    I have been using my iPhone just fine up until last night. I was in the store, and I wanted to look up some product reviews real quick to decide between two different items I was looking at. Problem was, no matter what I tried, I couldn't get a data connection. I had 4 bars, with the 3G indicator active, yet NOTHING would work. Even the app was stuck on "finding closest server" or something... Just nothing would connect at all.

    I tried turning on Airplane Mode, turning it off, turning off Cellular Data, waiting, turning it back on, closing all open apps, restarting phone... All of that, to no avail.

    Annoyed, I just made a purchase and went home. I thought maybe it was just because I was in the store. Nope... same thing at home, couldn't get it to connect. Wi-Fi would work, but 3G would do absolutely nothing.

    Then randomly an hour or so later, it worked fine.

    Now today, I was using 3G all day at work. Then I get home, and randomly decide to check something real quick while I was still in my car, and same as yesterday... nothing.

    Now, 30 minutes later, as I type this post, it has finally let me connect again... at a speed of 0.44 Mbps, according to SpeedTest. EDIT: Nevermind, now it's back to nothing.

    What gives?? What is going on with "America's most reliable 3G network"?? Is there something wrong with my phone? I never once had this happen on my Android phone. It's incredibly irritating that the 3G just happened to not work, twice, when I actually needed it.

    I don't want to go to Verizon because I'm sure it will be a pain to unjailbreak before I go, so I'm just wondering if anyone else has had this experience...
  2. TEG macrumors 604


    Jan 21, 2002
    Langley, Washington
    Call VZW's support. There may be a data outage, or they'll have another idea on how to fix it.

  3. ulbador macrumors 68000


    Feb 11, 2010
    I think if you poke around a bit, you'll see people having similar problems, though I haven't seen anything about hours.

    I know on my Verizon iPhone, I've seen this once or twice, but it's only been a "blip", not for anything more than a few seconds.


    My phone actually gets rid of the 3G symbol and displays the O symbol, for no apparent reason. Maybe yours is different.
  4. DDustiNN thread starter macrumors 68000


    Jan 27, 2011
    Yeah the O symbol has popped up a couple times, but only lasted for a couple seconds before switching back to 3G.

    So far I have not been able to do anything on 3G for the past hour. I thought it might have been an outage too last night, but now today it's doing the exact same thing.

    SpeedTest app finally worked again, and showed a Ping of 2488 ms, Download 0.07 Mbps, upload 0.00 Mbps.

    This is ridiculous.
  5. DDustiNN thread starter macrumors 68000


    Jan 27, 2011
    Hahaha... wow...

    I just got off the phone with Verizon's tech support, and he said there is actually an alert out for my area... He laughed as he read it, and said believe it or not, the alert says AT&T accidentally cut Verizon's fiber lines :)eek:) near me yesterday, and they're still working to get it fixed. It only affects some users in the area, but it explains why 3G works fine at work but not at home or at the store (which is near my place).

    Now that's a conspiracy if I've ever seen one, lol.

    Anyway he said there is no estimated resolution time yet, but normally this kind of stuff is fixed within 48 hours.
  6. ECUpirate44 macrumors 603


    Mar 22, 2010
    This is really frustrating. I lose 3G coverage every time I go into a building. Even when I am outside, it doesn't always connect to the 3G network. This pic was taken 5 minutes after I left a building and I was walking outside.

Share This Page