Verizon Wi-Fi Calling signal strength

Discussion in 'iOS 9' started by NJFP, Mar 6, 2016.

  1. NJFP macrumors 6502

    Joined:
    Feb 18, 2009
    #1
    It seems that ever since VZW updated to allow Wi-Fi calling, in the last two beta's (4&5) my VZW wi-fi signal comes and goes. It doesn't seem to matter if I'm at home or work or on a public wi-fi. My thinking is that it should grab and hold onto the setting until you're out of range from the wi-fi modem, no? Anybody else see this? Or is this how wi-fi calling works on all the carriers? I've sent in two reports to Apple, once on beta 4 and once on beta 5. Not sure if this is an Apple issue or VZW.
     
  2. HansumKingtut, Mar 6, 2016
    Last edited: Mar 10, 2016

    HansumKingtut Suspended

    HansumKingtut

    Joined:
    Aug 10, 2013
    Location:
    Virginia, USA
    #2
    It varies depending on the carrier. On AT&T it exhibits the Behavior you described, in which it will come and go. However I believe it has to do with the signal strength of the cell tower and the wifi. If the cell tower is stronger it drops wifi calling, if the wifi is stronger it will pop up wifi calling.

    However, on T-mobile, the second it connects to wifi, the 'T-mobile Wi-Fi' tag shows up and stays as long as I have wifi, even if the cellar service is strong, which it is in my area for T-mobile.

    Just my experience.
     
  3. campyguy macrumors 68040

    Joined:
    Mar 21, 2014
    Location:
    Portland / Seattle
    #3
    Both of my iPhones (6S on ATTWS, 6S+ on VZW) display wifi calling at about -104 "signal strength" or weaker, which I gleaned from the Field Test app. My brother's AK GCI phone roams on T-Mo down here in the Lower 48 - it's always "on" wifi calling when indoors since the signal sucks hard (pretty much always hovering around -108 to -110). Otherwise, the phones connect to the network - -104 seems to be the "magic number" on my handsets...

    My workaround to force wifi calling is to enable Airplane Mode to disable the cellular radio, then enable wifi - works for me right now.
     
  4. NJFP thread starter macrumors 6502

    Joined:
    Feb 18, 2009
    #4
    Thanks for the reply's. At least I'm not going batty!
     
  5. nooaah macrumors 68000

    nooaah

    Joined:
    Sep 3, 2009
    Location:
    Philadelphia, PA
    #5
    Honestly come to think why wouldn't you want to keep it in airplane mode while home? What other functionality is lost after you re-enable wifi and Bluetooth?
     
  6. Stuke00 macrumors 68000

    Joined:
    Oct 11, 2011
    Location:
    Collinsville,IL
    #6
    How do you enable wifi calling for Verizon? I have Verizon but never seen this option pop up
     
  7. DJLAXL macrumors 6502

    DJLAXL

    Joined:
    Jun 3, 2014
    Location:
    UT
    #7
    Mine does this too on Beta 5. Work wifi blocks me from updating so I have to wait to get home to update to 6. Drives me nuts lol. I have yet to make or take a call over WiFi though ha!
     
  8. kch50428 macrumors 6502

    kch50428

    Joined:
    Oct 30, 2015
    Location:
    North Iowa
    #8
    The wifi calling when enabled - seems to be cellular preferred and switches to wifi when you're connected to a decent enough wifi hot spot when the cellular signal goes below -100 and switches back when it goes to -95 or above... or when the the cellular signal is something less than two full dots to switch to wifi and back to cellular when there are 3 dots or stronger cellular signal available.
     
  9. K4LK macrumors 6502

    K4LK

    Joined:
    Jun 18, 2009
    #9
    Settings > Phone > Wi-Fi Calling. You must be running 9.3 beta 4 or later.
     
  10. campyguy macrumors 68040

    Joined:
    Mar 21, 2014
    Location:
    Portland / Seattle
    #10
    Agreed with enabling airplane mode while at home, my issue is that I travel a bit and try to not have that "habit" since E911 is set up for my home and it's too much of a PITA to change it.

    But, you're right, I can't think of anything that would be at issue, other than VZW's switching system might not route calls as expected. I tried their recent builds of their Messages+ app - the version that had wifi calling baked in - and it was a steaming POS for me in that it wouldn't connect to CenturyLink lines and often dropped calls at 14 seconds so I stopped using it. FWIW, I do this with my ATTWS line after noticing that wifi calling was on and off and on some days - indicative of a weak signal to me, so I'll leave airplane mode on - but I do notice some feedback (echo). Here's hoping Apple gets this worked out... :confused:
     
  11. Stuke00 macrumors 68000

    Joined:
    Oct 11, 2011
    Location:
    Collinsville,IL
    #11
    got it! Thanks!
     
  12. XTheLancerX macrumors 68000

    XTheLancerX

    Joined:
    Aug 20, 2014
    Location:
    NY, USA
    #12
    My Verizon iPhone 6 seems to hate wifi calling. It only enables at the weakest of the weak signal. Through most of my house, it doesn't enable. Only tends to enable in the bathroom which is smack dab in the middle of the house with no windows, service drops to about -114 in there but if I cup my hands around the antennas I can force my phone to no service, it's weak enough. I still pull about 5-10mbps at like 60ms ping though so surprisingly good at such a weak signal.

    Anyway, I moved from the bathroom to the living room, it went from -118 to -107. Wi-Fi calling disabled on its own. What? -107 is still pretty dang weak. Forced it back with airplane mode and my phone was like "Oh okay yeah that cell signal was crap compared to this". My phone tends to hang onto wifi calling for awhile if I force it with airplane mode but then disable again. On its own, it's extremely fickle.

    I don't like to leave airplane mode on because my phone refuses to send MMS or media in iMessage even when on Wi-Fi Calling with airplane mode enabled. I'm not sure if it's a bug or what. Everything should go through Wi-Fi anyway with iMessage, so I don't get it...

    Will your battery still drain if you have wifi calling on but bad cell signal (airplane mode isn't on)?
     
  13. maxsix Suspended

    maxsix

    Joined:
    Jun 28, 2015
    Location:
    Western Hemisphere
    #13
    Based on what I'm reading here I must be lucky. My Verizon iPhone 6 Plus WiFi calling is quick to lock onto a signal, holds it well and voice quality is quite clear and pleasant. I'm very happy.
     
  14. gordon1234 macrumors 6502a

    Joined:
    Jun 23, 2010
    #14
    For me it enables the second I get into my house and never switches to cellular. My signal is usually-120 or worse indoors (any calls attempted drop within seconds), so that seems like the proper behavior.
     
  15. buck1127 macrumors 6502a

    buck1127

    Joined:
    Jan 12, 2011
    #15

    I had wifi calling icon next to cell signal on Verizon but it went away today for some unknown reason
     
  16. zorinlynx macrumors 601

    zorinlynx

    Joined:
    May 31, 2007
    Location:
    Florida, USA
    #16
    The reason why the phone will prefer the cellular network with a strong signal is simple: Voice calls receive priority on the cellular network. They would prefer you to be on the cellular network and have a high quality phone conversation, than to be on WiFi where they can't guarantee the quality of the connection.

    I don't think signal strength is the only factor. I've been on AT&T WiFi calling even with a full signal, usually in crowded places where the cel tower is overburdened. I think the decision to move you to WiFi is based on signal strength, tower utilization, and maybe even the quality of the WiFi network you're on.

    It makes sense that they want you to have the absolute best quality possible when you make a voice call. Voice is a tiny burden on the network these days; there's not much benefit to moving a call off the tower without a good reason.
     
  17. gordon1234 macrumors 6502a

    Joined:
    Jun 23, 2010
    #17
    I had something similar happen a few days ago. What fixed it was so turn off Wi-Fi calling, restart, the turn it on again.
     
  18. electronicsguy macrumors 6502a

    electronicsguy

    Joined:
    Oct 12, 2015
    Location:
    Pune, India
    #18
    You loose the ability to be triangulated by cell towers or have your phone connect to the Stingray instead of a legitimate tower :)
     
  19. nooaah macrumors 68000

    nooaah

    Joined:
    Sep 3, 2009
    Location:
    Philadelphia, PA
    #19
    The only real downside is no sms, right?
     
  20. C DM macrumors Westmere

    Joined:
    Oct 17, 2011
    #20
    Well, if you have WiFi Calling then SMS should come over that just as voice calls would.
     
  21. briankeith513 macrumors 6502a

    briankeith513

    Joined:
    Feb 6, 2011
    Location:
    Atlanta, GA
    #21
    Wifi calling on the public beta has been wonderful for me. I've gone for so long with poor service in my home, and now I can make crystal clear calls, without drops.
     
  22. electronicsguy macrumors 6502a

    electronicsguy

    Joined:
    Oct 12, 2015
    Location:
    Pune, India
    #22
    wifi calling includes all capabilities. Why would you lose sms?
     
  23. aldrinjtauro macrumors regular

    Joined:
    Jul 3, 2014
    Location:
    Birmingham, AL
    #23
    I've noticed that things like "It will take you X minutes to get to XXXXXX", or the weather under Today in the NC disappear if you're on Airplane Mode but have Wi-Fi turned on. Not sure why.
     
  24. BigMcGuire Contributor

    BigMcGuire

    Joined:
    Jan 10, 2012
    Location:
    California
    #24
    I also assumed I would lose SMS abilities with Airplane Mode turned on (but WiFi and VZW Wi-Fi calling on).

    But, I just tested it. I used Google Voice to text my cellphone number and I received it instantly in my Apple Messages app (green for SMS not iMessage).

    I also tested MMS - sending a pic from Google Voice to my iPhone and it worked. Sent a pic from my iPhone to Google Voice (worked).

    Also tested iMessage SMS and MMS to my wife (she is not in airplane mode, I am) and it worked.

    So looks like full functionality on my Verizon iPhone 6+ in Airplane Mode with WiFi turned on and WiFi calling turned on.
     
  25. electronicsguy macrumors 6502a

    electronicsguy

    Joined:
    Oct 12, 2015
    Location:
    Pune, India
    #25
    well ya, that's how it's supposed to work.
     

Share This Page