Very complex problem with current and past OS caused by wine

Discussion in 'macOS High Sierra (10.13)' started by uneasyE, Apr 27, 2018.

  1. uneasyE macrumors newbie

    Joined:
    Apr 27, 2018
    #1
    Starts very simple.

    Mac Version of a game (basic .app file)
    Either saying The application * can’t be opened or it bounces in the dock and disappears immediately.

    This started on El Capitan.
    I tried to use Wine to run the windows version of the previously mentioned game using all the information found here.

    Winehq.org

    It never worked no matter what I did,
    I tried all different versions and other similar applications (PlayOnMac etc.)
    I tried digging deep and figuring out why my wine would not run my .exe so I went on the WineHq forums and started using the terminal commands I found from people with similar problems.
    Again this did nothing.

    I am normally very knowledgeable when it comes to computers but after a certain point I was in over my head and did something that reoccurs no matter what.

    After giving up on trying to run an .exe
    I went to start the Mac .app version of the game ( wanted two installs for two versions one of which is windows only )
    Only to find that it won’t open.
    “The application * can’t be opened.”
    Or it bounces in the dock for a split second and disappears.



    I have tried everything.. redownloading the game, disk repairs, double checking and fixing permissions,
    Updating my current version of OS and trying to open it, then updating to Sierra, then wiping my hard disk and trying again. I’ve tried every troubleshooting tip on the subject also. It STILL happens. I’m currently reinstalling Sierra for the second time hoping it works..


    Any one have any advice?
    I’d really appreciate the help, this is such a complex problem that I’m worried it can’t be fixed..
     
  2. meme1255 macrumors 6502a

    Joined:
    Jul 15, 2012
    Location:
    Czech Republic
    #2
    Do you have "Use Mac display driver" or XQuartz installed?
     
  3. uneasyE thread starter macrumors newbie

    Joined:
    Apr 27, 2018
    #3
    xQuartz was installed yes.
    I went to every length possible trying to get my game to work but I definitely got in too deep.
     
  4. meme1255 macrumors 6502a

    Joined:
    Jul 15, 2012
    Location:
    Czech Republic
    #4
    What game is it?
     
  5. NoBoMac, Apr 29, 2018
    Last edited: Apr 29, 2018

    NoBoMac macrumors 68000

    Joined:
    Jul 1, 2014
    #5
    As post above mentions, what game, as MAYBE it is only supported on an older version of OS X. So, may not be fixable.

    Have you looked at the system log in Console.app to see what error messages are being thrown at program start? Per above paragraph, a system library and or binding to a library might not be present in El Cap and higher.
     
  6. uneasyE thread starter macrumors newbie

    Joined:
    Apr 27, 2018
    #6
    I got the game running after the second reinstall, that’s not the problem anymore unfortunately :(

    The game may run but my computer is doing some very weird things...
    Every time it sleeps I have to pull my keyboard plug out and put it back to get it to work.
    When I start to stream on Apple TV it gives me a blue screen for a few seconds then it stops streaming and if I try again it works the second time.
    On top of that the loading time on startup has tripled. And a few other minor glitches.

    Doesn’t make much sense to me how these problems could be persisting after two complete hard drive wipes.
     
  7. uneasyE thread starter macrumors newbie

    Joined:
    Apr 27, 2018
    #7
    bump

    Still having very strange problems with my computer coming out of sleep,
    the amount of time it takes is at least triple that of what it was before.

    And the screen sometimes flashes white or blue.
    --- Post Merged, May 3, 2018 ---
    The game is no longer the problem. :(
     
  8. uneasyE thread starter macrumors newbie

    Joined:
    Apr 27, 2018
    #8
    *Mostly solved*


    Just Incase anyone comes across this problem in the future.

    After a complete wipe and after fixing my permissions with CCleaner everything started working much better.
    I have used CCleaner for years but did not expect it to do anything that the Apple repair couldn’t..

    Am now using the most current OS with no reported problems yet.
    Fingers crossed.
     

Share This Page