iPod touch Very frustrating JB Experience, would like assistance please.

Discussion in 'Jailbreaks and iOS Hacks' started by sinodira, Feb 19, 2012.

  1. sinodira macrumors newbie

    Joined:
    Feb 19, 2012
    #1
    Hi, I'm new to this forum, seemed like as good a place as any to get help with my issues =P

    I have a third generation iPod touch running iOS 4.2.1 I jailbroke it earlier today with greenpois0n through terminal (I'm on a macbook pro with OSX 10.7.3 and the latest iTunes) and it worked fine, but my loader app is empty so I couldn't install Cydia. Supposedly this is due to the greenpois0n site being down and they recommended installing Cydia through Redsn0w. Which I tried, but when it gets to the end of the install it says "exploiting through limera1n" briefly and then says "unexpected error please reboot or use a different usb port" and I've been trying both for several hours now and am very frustrated. If there is any way to either:
    a)Fix the loader app so that it can install Cydia like it should.
    b)Fix Redsn0w so it can install Cydia like IT should.
    c)Install Cydia manually so I don't have to deal with Redsn0w or Greenpois0n for a very long time.

    that would be just spectacular.
    Thanks in advance,
    Sinodira
     
  2. TheKnowledgeGuy macrumors member

    TheKnowledgeGuy

    Joined:
    Apr 23, 2010
    #2
    Probably not, but maybe your version of Redsn0w is too new? Upgrade to iOS5 or download an older version of redsn0w.
    Also, I have no idea, but, with the 'USB port' error, is your device plugged in by a USB cable plugged in directly into your computer?
     
  3. Axgema macrumors newbie

    Joined:
    Jan 12, 2012
    #3
    i know your problem. I'm pretty sure the reason it is saying something funky like that is because redsnow gets its ispw's directly from apple, and apple no longer holds onto ios 4.2 ispw's. so redsnow cannot identify or do its process. you can try downloading the ispw from internet and using a custom ispw, but i dont really know how that works. what i did for my friend's ipod 2g a few weeks ago was i went in greenpois0n.com, and downloaded the corresponding file (something like greenpois0n rc5). but you should see a page with something like lonks to download the tools and just pick the right one and you're good. its the only suggestion i can give you unless you upgrade to ios 5, in which case redsnow works miracles.
    btw i have a macbook too so i know they all work on macs
     
  4. sinodira thread starter macrumors newbie

    Joined:
    Feb 19, 2012
    #4
    Sorry, should have said I got it fixed, There is some packages you can download, that you can SSH into the iPod, anyone who is having troubles in the future and finds this thread should watch this video, and realize that there is no such thing as a third generation iPod touch in 16GB or 8 GB and that its most likely a 2nd gen which is why it isnt working, just run greenpois0n and then follow the steps in this very helpful video. =P

    http://www.youtube.com/watch?v=l7IUPQFOv6M&list=FLiCRxegcFev7LoH4Y1JGZ1A&feature=mh_lolz
     
  5. TheKnowledgeGuy macrumors member

    TheKnowledgeGuy

    Joined:
    Apr 23, 2010
    #5
    Good to hear!

    Also, another obvious thing that would work which I forgot to mention is using redsn0w's Custom IPSW option to load your old iOS version's file.
     

Share This Page