very hot and burning smell

jdc5294

macrumors newbie
Original poster
May 17, 2013
2
0
So I'd say about four years ago I installed this product in my 2003 mercury sable. At the time I had an 80gb iPod and it worked beautifully. About a year and a half ago I got an iPhone 4S and continued to use it with that device. It's not compatible with charging an iPhone but it still played the music through my car, I can live with that.

Last night, after about 30 seconds of plugging it in to that device I smelled a burning rubber smell, and when I picked up my iPhone I realized it was getting VERY hot, to where I was no longer able to hold it, and I have pretty tough hands I'm a construction worker. The temperature warning that usually accompanies this didn't happen. I immediately tried to turn it off by holding the sleep button, but after it shut down it turned itself right back on, about 5 times before I gave up. I unplugged it from the device obviously, and it cooled down. I took a picture of the dock this morning. Any ideas?

EDIT: As of right now the phone is working as if nothing ever happened, except that smell is hanging around a bit.
 

Attachments


Mrbobb

macrumors 601
Aug 27, 2012
4,989
192
Hazard to guess dirt has caused a electrical short. Obviously the dock is now damaged and needs to be replaced. I hope it did not damage iPhone.
 

jdc5294

macrumors newbie
Original poster
May 17, 2013
2
0
Hazard to guess dirt has caused a electrical short. Obviously the dock is now damaged and needs to be replaced. I hope it did not damage iPhone.
I should also mention it was fine last night charging with a wall charger
 

Gav2k

macrumors G3
Jul 24, 2009
9,217
1,585
There is a lot of dust and crap in your dock port. That need cleaning out.