Very nearly a Nightmare! Be Warned!

Discussion in 'MacBook Pro' started by heyapple, Mar 28, 2013.

  1. heyapple macrumors newbie

    heyapple

    Joined:
    Mar 22, 2013
    Location:
    Blighty
    #1
    My wife is multi-lingual and uses the international keyboard options in the system prefs to access a few different language keyboards.

    Not a problem on my desktop mac but not so on my rMBP...

    When I went to wake it up and put in my access code, it refused to accept it - doing a wiggly shake screen thing. My wife (who had just used it) was upset and insisted she had done nothing to it!

    We finally figured out that she'd had it on another language keyboard and had let it go to sleep. Thankfully she was able to work out where all the relevant keys were and get into it again, but...

    ...that was only thanks to the fact that the language was 'Latin Character' based. Another of her languages uses Cyrillic. The implications (sickening) slowly dawned on me and I immediately removed that option from the languages in the tool bar.

    If it had gone to sleep with a Cyrillic keyboard, then whatever we tapped into it would have been unrecognisable by my mbp.

    My desktop sleeps but I don't use a code to get in, as only family have the use of it, so it's never been a problem until now.

    Be warned. I have no idea how to get into a mac if this ever happened.
     
  2. eawmp1 macrumors 601

    eawmp1

    Joined:
    Feb 19, 2008
    Location:
    FL
    #2
    How about you all use numeric logins? Aren't the number keys consistent across the languages?
     
  3. ThE.MeSsEnGeR macrumors 6502a

    ThE.MeSsEnGeR

    Joined:
    Jan 26, 2009
    Location:
    Caracas, Venezuela
    #3
    Don't worry about that, turn the international keyboards back on. I also have Arabic along with the English keyboard. Just make sure to turn on this option in System Prefrences -> Users & Groups -> Login Options.

    [​IMG]

    ;)
     
  4. justperry macrumors 604

    justperry

    Joined:
    Aug 10, 2007
    Location:
    In the core of a black hole.
    #4
    Good catch, it should be on by default, now, if that option is not there and someone else uses the Mac you are in trouble.
     
  5. heyapple thread starter macrumors newbie

    heyapple

    Joined:
    Mar 22, 2013
    Location:
    Blighty
    #5
    Thanks for that. I've made that change.
     
  6. Ploki macrumors 68000

    Joined:
    Jan 21, 2008
  7. adjeff8 macrumors 6502

    adjeff8

    Joined:
    Nov 18, 2012
    #7

    OMG-Thanks for the warning. I work many months a year in Bulgaria and am sorta learning the Language. I have a Cyrillic keyboard on my iPhone and iPad and I use it often. Glad to know to keep that part of my life away from my RMBP when I get it
     
  8. Ploki macrumors 68000

    Joined:
    Jan 21, 2008
    #8
    Read the rest od the thread ;)
     
  9. ThE.MeSsEnGeR macrumors 6502a

    ThE.MeSsEnGeR

    Joined:
    Jan 26, 2009
    Location:
    Caracas, Venezuela
    #9
    I'm glad I helped :)
     

Share This Page