Very new 15" rMBP shutdown is VERY SLOW?

Discussion in 'MacBook Pro' started by Imola Ghost, Jul 14, 2013.

  1. Imola Ghost macrumors 65816

    Joined:
    Mar 21, 2009
    #1
    I've had this brand new 15" rMBP for several months now and it takes about 2 minutes to shut down a majority of the time.

    Ideas for what might be going on?
     
  2. newdeal macrumors 68020

    Joined:
    Oct 21, 2009
    #2
    Trying to close apps and unmount network storage perhaps? That is just a guess
     
  3. Imola Ghost thread starter macrumors 65816

    Joined:
    Mar 21, 2009
    #3
    No networked drives are connected and it happens even if I just booted up.
     
  4. DarkoDonnie macrumors member

    DarkoDonnie

    Joined:
    Jun 18, 2013
    #4
    For me, sometimes safari or iTunes won't quit for a very long time (usually a network thing) and the shut down will hang. The second i force quite the "sticky" app it's an immediate shut-down.

    Have you tried that? after hitting shut-down, looking and what apps are open, and force quitting to see if any are causing the hang.
     
  5. lagisibuk macrumors 6502

    Joined:
    Jun 25, 2013
    Location:
    Always Somewhere
    #5
    please fo to POWER PREFERENCE
    and then "uncheck" ENABLE POWER NAP..".
    have fun :D
     
  6. falconeight Guest

    falconeight

    Joined:
    Apr 6, 2010
    #6
    Ive had multiple macs in the last two years and some tai awhile to shut down and some don't. Im guessing its the software running at the time. I have yet to have one take 2 minutes to shut down. Most of the time its about 1 minute on the slow end.
     
  7. Watabou macrumors 68040

    Watabou

    Joined:
    Feb 10, 2008
    Location:
    United States
    #7
    I don't have an rMBP but I did have very slow shutdowns too at one point so I searched around for a solution until I tried this solution and it worked for me. Try it out:

    In terminal, enter:

    Code:
    rm ~/Library/Preferences/com.apple.desktop.plist
    This removes the desktop plist file (don't worry as it will be regenerated shortly.)

    Then enter:

    Code:
    killall Dock
    Then try to shutdown. For me, shutdown was almost instanaeous compared to the two to three minutes I was first getting which was a huge difference. Hopefully this will work for you too. :)
     
  8. lagisibuk macrumors 6502

    Joined:
    Jun 25, 2013
    Location:
    Always Somewhere
    #8
    please fo to POWER PREFERENCE
    and then "uncheck" ENABLE POWER NAP..".
    have fun :D
     

Share This Page