Very new to the whole jailbreaking thing, so I updated through itunes to 3.1

Discussion in 'Jailbreaks and iOS Hacks' started by iKatianarie, Oct 9, 2009.

  1. iKatianarie macrumors member

    Joined:
    Apr 27, 2009
    #1
    Point is, I'd like to know if it's POSSIBLE to unlock the phone now that it has a baseband of 5.11.07, and no, it doesnt have a bootloader of 5.8.
     
  2. appleguy123 macrumors 603

    appleguy123

    Joined:
    Apr 1, 2009
    Location:
    15 minutes in the future
  3. dhlizard macrumors G4

    dhlizard

    Joined:
    Mar 16, 2009
    Location:
    The Jailbreak Community
    #3
    Just so you won't get unrealistic hopes, there is a group which now claims to have the software to unlock the 5.11.xx. baseband.

    Based on what I have read, I personally, along with more than a few others, believe this is a hoax, but we shall see.

    This group has promised to release these tools on Sunday, so we shall know soon.

    I started a thread here on their claims if you are interested in reading it.

    If they are able to do this, it is a wonderful breakthrough !
     
  4. Skengman macrumors member

    Skengman

    Joined:
    Nov 29, 2008
    Location:
    Essex/London
    #4
    Anyone know where I can get the 3.1 ipsw? can't find it anywhere
     
  5. dhlizard macrumors G4

    dhlizard

    Joined:
    Mar 16, 2009
    Location:
    The Jailbreak Community
    #5
    The official Apple IPSW or a custom restore IPSW (pwnage Tool version)
     
  6. impulse462 Suspended

    impulse462

    Joined:
    Jun 3, 2009
    #6
    If you wanted to potentially jailbreak your phone, why would you upgrade...

    That is probably the LAST thing you should have done.
     
  7. iKatianarie thread starter macrumors member

    Joined:
    Apr 27, 2009
    #7
    Did you not get the "Im new to this" part?
     
  8. yentrog31 macrumors regular

    yentrog31

    Joined:
    Oct 10, 2009
    Location:
    RGGnDFW
    #8
    LOL..ouch! ...nothing a bit of humor in these dire days....
     
  9. impulse462 Suspended

    impulse462

    Joined:
    Jun 3, 2009
    #9
    No, I did see that

    However, i'm pretty sure that you were aware that jailbreaking isn't "supported" by apple and that it is a "hack" of a device.

    Also I'm pretty sure you would have known that when theres an update to any firmware/OS, it's usually because it improves something, or tries to break unsupported activities(as such with apple) such as "hacking."

    but hey I don't know you, but I know you're not that stupid.(and no, this is not an insult)
     
  10. thelatinist macrumors 603

    thelatinist

    Joined:
    Aug 15, 2009
    Location:
    Connecticut, USA
    #10
    That's a pretty big "if."

    OP: I don't think anyone here knows if it is possible; in fact, I'm not sure anyone knows if it is possible. The Dev Team, whose judgment in this area I would definitely trust, has said it will be very difficult and perhaps impossible. As far as I know, nobody is actively looking for a way to accomplish it.
     
  11. Mystikal macrumors 68020

    Mystikal

    Joined:
    Oct 4, 2007
    Location:
    Irvine, CA
    #11
    On this note, musclenerd just showed a 3.1.2 iphone with 4.26.08 baseband by using a custom IPSW, so thats good news.

    [​IMG]
     
  12. thelatinist macrumors 603

    thelatinist

    Joined:
    Aug 15, 2009
    Location:
    Connecticut, USA
    #12
    Not sure what this has to do with this thread (which is about phones already on 5.11.07), but it is cool.
     
  13. impulse462 Suspended

    impulse462

    Joined:
    Jun 3, 2009
    #13
    There probably is a way to unlock 5.11.07, but since 4.26.08 is already unlocked its probably just easier to use custom ipsw's that preserve the baseband instead.
     
  14. dhlizard macrumors G4

    dhlizard

    Joined:
    Mar 16, 2009
    Location:
    The Jailbreak Community
    #14
    If there was a known exploit, believe me, the unlock would be a priority. But since the known exploits were all deleted in the 3.1 firmware, at least for the time being, there is no where to go.

    Easier has nothing to do with it, I assure you.
     
  15. thelatinist macrumors 603

    thelatinist

    Joined:
    Aug 15, 2009
    Location:
    Connecticut, USA
    #15
    If the Dev Team knew of a way, I'm sure they'd tell us so. They've made preserving the baseband their priority because they don't have one. One may be found eventually...but implying that the Dev Team is lazy is uncalled for.
     
  16. -aggie- macrumors P6

    -aggie-

    Joined:
    Jun 19, 2009
    Location:
    Where bunnies are welcome.
    #16
    I didn't read that he was implying that.:confused:
     
  17. impulse462 Suspended

    impulse462

    Joined:
    Jun 3, 2009
    #17
    lol what are you talking about...if you had an easier way to do something I'm pretty sure you would do it also.

    Once 3.1 becomes more mainstream and more phones that come from the factory are on 5.11.07 and IF there is an exploit, i'm sure the dev team would unlock it.

    i dont understand why people take so much offense if someone calls the dev team lazy (which i'm not). Everything they do is for free. I understand that, but its not a personal attack if someone calls them lazy (which i'm not).

    Its the same thing as 2.2.1, however in that case there was no known exploit. 2.2.1 had a baseband of 2.30.03. Upgrading to 4.26.08 is no different than upgrading to 5.11.07 from 4.26.08. Sure 4.26.08 is a bigger jump, but it's still just an upgrade, granted there was more time from 2.30.03 to 4.26.08 with all the 3.0 betas which is where the exploit was found at first I'm sure.
     

Share This Page