Very slow airport extreme

Discussion in 'Mac Accessories' started by ragz, Mar 16, 2013.

  1. ragz macrumors newbie

    Joined:
    Dec 6, 2006
    #1
    I have a decently fast internet connection. When I connect my imac via the ethernet to the DSL modem, the speedtest.net website shows as good as 20-25mbps downloads and upoads.

    However when the same ethernet cable it connected to an airport extreme, the iMac speeddtest.net test shows very low download speeds of 3-4mbps but higher uploads of about 10-12 mbps.

    I have created a 5ghz network as well. These tests are conducted with the extreme box right next to the iMac and signal strength is FULL.

    Please advice.

    Thanks
    Anurag
     
  2. FreakinEurekan macrumors 68040

    FreakinEurekan

    Joined:
    Sep 8, 2011
    Location:
    Eureka Springs, Arkansas
    #2
    Try plugging the iMac into the router via Ethernet, narrow it down to a routing issue vs. a wifi issue
     
  3. rgarjr macrumors 603

    rgarjr

    Joined:
    Apr 2, 2009
    Location:
    Southern Cal
  4. ragz thread starter macrumors newbie

    Joined:
    Dec 6, 2006
    #4
    Thanks for the tips. When the imac is connected directly to the router its very fast. Its the wifi that is slowing things down. I will reset the extreme. One to note is that I have 2 extremes and 2 express. All give slow connectivity. How can this be possible?
     
  5. linds15 macrumors 6502a

    Joined:
    Oct 16, 2012
    Location:
    Great White North
    #5
    all 4 doing it is incredibly odd. i had one with the issue and found doing a complete reset of it helped. let us know how it goes for you
     
  6. FreakinEurekan macrumors 68040

    FreakinEurekan

    Joined:
    Sep 8, 2011
    Location:
    Eureka Springs, Arkansas
    #6
    Are they slow only for this iMac, or for any computer attached to them?
     
  7. ragz thread starter macrumors newbie

    Joined:
    Dec 6, 2006
    #7
    I have tried connecting via my 2009 MBP and my two iOS devices (ipad 3 and iphone 5).

    The ios devices get as high at 8mbps on the local 3G network.
     
  8. BIG-b macrumors newbie

    Joined:
    Apr 1, 2013
    Location:
    Indiana
    #8
    Did you figure out what the cause of the slow ethernet speeds were ?

    I have the same issue where anything connected to ethernet is only seeing a maximum of 60 megabits (even though it is showing negotiated at 1Gigabit)

    I swapped for a new unit at Bestbuy and have exactly the same issue (My wireless is faster than my ethernet)

    Any ideas??
     
  9. drsox macrumors 65816

    drsox

    Joined:
    Apr 29, 2011
    Location:
    Xhystos
    #9
    What's your config ? Are there problems with Internet speeds or internal LAN speeds. Are your speeds in MBps or Mbps ?
     
  10. dmax35 macrumors 6502

    Joined:
    Jun 21, 2012
    #10
    What radio mode do you have your APE set to & the 5GHZ channel set to? You may be getting interference with local neighbors channel.

    Try using a wifi explorer to see your traffic.
     
  11. opinio macrumors 65816

    Joined:
    Mar 23, 2013
    #11
    Wifi could be conflicting with usb3 if you have a device close.
     

Share This Page