Very slow connection on Wireless N?

Discussion in 'iMac' started by hawk2417, Oct 15, 2007.

  1. hawk2417 macrumors newbie

    Joined:
    Aug 9, 2007
    #1
    I have a Linksys WRT150N router, and I'm POSITIVE I have an N card on my iMac as it was bought just four months ago, but yet I still experience a very slow connection on my iMac. Also, sometimes I have trouble reconnecting to the router, (when I disconnect/connect to see if it quickens the speed) and it will just say that my network was not able to be connected to.

    I have two other computers on this network, one is rarely used but always on (connected), and I have an Xbox 360 on the network.

    I appreciate your help.
     
  2. EspressoMac macrumors newbie

    Joined:
    Aug 28, 2007
    Location:
    Coral Gables, FL
    #2
    When you use both N devices (your iMac) and some other device that is not an N device, the entire network slows down to accomodate the slower devices. There is a way to mix networks to keep them separate if you still have the older, slower router. See this:

    http://www.macworld.com/2007/06/secrets/july07mobilemac/index.php

    Hope that helps.
     
  3. CashGap macrumors 6502

    CashGap

    Joined:
    Sep 15, 2007
    Location:
    Music City, USA
    #3
    "When you use both N devices (your iMac) and some other device that is not an N device, the entire network slows down to accomodate the slower devices. There is a way to mix networks to keep them separate if you still have the older, slower router. See this:"

    You are spot-on correct.

    I added an Airport Express for my Tivo and old Windoze PC, that keeps the G off my Airport Extreme N network and the difference was dramatic.
     
  4. hawk2417 thread starter macrumors newbie

    Joined:
    Aug 9, 2007
    #4
    Okay, still one problem, the other computers on my network are both Windows, this is the only Mac.
     
  5. EspressoMac macrumors newbie

    Joined:
    Aug 28, 2007
    Location:
    Coral Gables, FL
    #5
    It doesn't matter if they are Windows or Mac. They are communicating via a slower version of wireless connection (802.11b or 802.11g or whatever). Your Mac is the only one that connects via the fast 802.11n version.

    Try this. Shut down everything and turn everything off. Turn on only your Mac and your router. See if that makes a speed difference.
     
  6. zakatov macrumors 6502a

    zakatov

    Joined:
    Mar 8, 2005
    Location:
    South Florida
  7. TPrather302 macrumors newbie

    Joined:
    Jan 10, 2008
    #7
    The Right Answer

    Actually all of the previous answers are wrong.

    I had the exact same problem.

    The linksys router does not support the full wireless N capability on the mac.

    The linksys is Draft-N, so you need to set the router to only broadcast on G & B mode. It will fix all of the problems
     
  8. killmoms macrumors 68040

    killmoms

    Joined:
    Jun 23, 2003
    Location:
    Washington, DC
    #8
    No, EVERYTHING 802.11n is "draft-n" right now, not just the Linksys. N is not a finished standard, so everyone's n-level equipment is draft-n.
     
  9. Matek macrumors 6502a

    Joined:
    Jun 6, 2007
    #9
    How do you define a "slow" connection? I hope you're not expecting to actually reach the advertised 270-300 Mbps. According to different reviews I've read, even when you're sitting 2 feet away from the router, it's difficult to achieve more than 50-60 Mbps on average. Which translates to about 7.5 MB/s in the most ideal conditions.
     

Share This Page