Very slow Graphics Performance with rMPB

Discussion in 'MacBook Pro' started by GuitarNut, Sep 15, 2012.

  1. GuitarNut macrumors newbie

    Joined:
    Sep 15, 2012
    #1
    So this is no fun, it seems like my retina macbook pro isn't working right. In Windows 7 I have installed the latest nVidia drivers and I've only managed to get 770 in 3DMark 2011. So I'm not quite sure what is wrong. Am I missing something in trying to set this thing up? I've tried over clocking it but I don't quite understand the Performance settings.

    If you guys could help, that would be wonderful
    Thanks
     
  2. Mr MM macrumors 65816

    Mr MM

    Joined:
    Jun 29, 2011
    #2
    whats your power plan?

    Run Hwinfo and nvidia inspector, let them record the clocks of the gpu

    Clean install the nvidia drivers, i.e. boot into safe mode, use driver sweeper, remove all the drivers, install those again
     
  3. icecoldart macrumors member

    icecoldart

    Joined:
    Mar 30, 2012
    Location:
    Europe-Poland
    #3
    My bet is that it uses the intel integrated GPU instead of the Nvidia's one.
    Something is obviously wrong.
     
  4. GuitarNut thread starter macrumors newbie

    Joined:
    Sep 15, 2012
    #4
    Yeah it seems like its on Intel as far as speed goes. But it's all reporting the 650m and clocks show core 900Mhz and mem 1025Mhz I believe is what I saw

    I notice in GPU-z it changing clocks all the time, but it seems to be steady when in a game...just very very slow. I changed the power profile already to High Performance and still nothing.

    Any other ideas?
     
  5. GuitarNut thread starter macrumors newbie

    Joined:
    Sep 15, 2012
    #5
    I seemed to have fixed it by messing with the Nvidia Control Panel. Now I got 3010 with the overclock in 3DMark 2011. Temps around 74c. Pretty amazing. Played Battlefield 3 on Ultra for a good hour.

    Amazing notebook.
     
  6. Cassadian macrumors regular

    Joined:
    Sep 4, 2012
    #6
    Can you please tell us what you did to fix it?
     
  7. GuitarNut thread starter macrumors newbie

    Joined:
    Sep 15, 2012
    #7
    So in the Nvidia Control Panel there is a Manage 3D settings. I think the biggest option to change was something about Multiple Graphics Cards or Single Graphics Card. I selected Single and also changed as much stuff to application specific as possible, and performance when needed.

    I hope that helps. I used MSI Afterburner for the overclock.
     
  8. MiG123 macrumors newbie

    Joined:
    Aug 29, 2012
    #8
    no way its running iGPU in bootcamp. tat alone will mean OP has achieved a revolutionary breakthrough in the history of bootcamp...
     
  9. GuitarNut thread starter macrumors newbie

    Joined:
    Sep 15, 2012
    #9
    I know it wasn't on the iGPU. I just the speeds were as if I was. I think the Control Panel had everything maxed out.
     

Share This Page