Very slow "Open with"

Discussion in 'Mac Pro' started by fredr500, Aug 4, 2014.

  1. fredr500 macrumors regular

    Joined:
    Apr 12, 2007
    #1
    I have a 5,1, 16GB Ram, 512GB SSD and 4 spinners. Boot drive is SSD.

    When I right click a file and accidentally pause over "Open with" I get a beach ball anywhere from 15-90 seconds, then all is well. The pain is that I can't do anything else in Finder while this is spinning.

    Any idea what is causing this? One thought I just had is that I cloned my old 1TB drive to the SSD and didn't delete anything. Is it looking at 'Applications' on both drives?

    Everything else is pretty zippy, just Open With is slow.
     
  2. bax2003 macrumors 6502a

    bax2003

    Joined:
    Dec 25, 2011
    #2
    Try to rebuild open with cache with this terminal command: (just paste it, and reboot)

    /System/Library/Frameworks/CoreServices.framework/Frameworks/LaunchServices.framework/Support/lsregister -kill -r -domain local -domain system -domain user
     
  3. brand macrumors 601

    brand

    Joined:
    Oct 3, 2006
    Location:
    127.0.0.1
    #3
    As with any command that is provided to you on the Internet I would encourage you to research the command prior to using it just so you fully understand what you are doing.

    I am not saying that the above command is harmful or malicious. Just that you are responsible for any command that you run on your own computer.
     
  4. fredr500 thread starter macrumors regular

    Joined:
    Apr 12, 2007
    #4
    Thanks Brand.

    From Krypted:
    The lsregister command is used to query and manage the Launch Services database, or the database that is used to determine the default application used to open files of various types. lsregister is part of Core Services, and stored in /System/Library/Frameworks/CoreServices.framework/Versions/A/Frameworks/LaunchServices.framework/

    The database can become pretty large and unwieldy. There are applications registered in the local domain, system domain and each user’s domain. You can always clear these out using the following command, which also recursively rebuilds based on the output of a -lint option:
    /System/Library/Frameworks/CoreServices.framework/Versions/A/Frameworks/LaunchServices.framework/Versions/A/Support/lsregister -kill -r -domain local -domain system -domain user

    So it appears I may need to reset the default apps used to open different filetypes. Not a problem, I need to change some anyway.

    ----------

    And....it works! Thanks, much better. Not sure if the defaults need to be fixed but not a big deal, the Open with is as fast as Open.
     

Share This Page