Very slow Samsung 840 pro speed

raniel

macrumors regular
Original poster
Jan 2, 2011
144
92
Ph
Hi

Just bought a new Samsung 840 Pro 256GB and put it in a USB 2.0 enclosure, I only got 35-40 MB/s read & write...

yeah I know usb 2 speeds are very slow, but not this slow.


Please help me
Thanks
 

Attachments


Livewings

macrumors regular
Dec 16, 2012
196
3
Hi

Just bought a new Samsung 840 Pro 256GB and put it in a USB 2.0 enclosure, I only got 35-40 MB/s read & write...

yeah I know usb 2 speeds are very slow, but not this slow.


Please help me
Thanks
You bought one of the best SSDs around and you put it in a $2 enclosure? :rolleyes:
 

dusk007

macrumors 68040
Dec 5, 2009
3,386
61
It is a bit weird to run an SSD in a USB 2.0 enclosure.
I never get beyond 35MB on mine and if I attach it on the hub instead of directly at a port it isn't even that. Only 25-30.
40MB/s is an incredible speed for USB 2.0 and about the best you can possibly expect. I would be proud of those controllers on both ends.
 

BuCkDoG

macrumors 6502a
Jun 13, 2013
535
178
I agree with everyone else. Run it on USB 3 or SATA. USB 2 isn't where you want to be with an awesome SSD like that one.
 

raniel

macrumors regular
Original poster
Jan 2, 2011
144
92
Ph
You bought one of the best SSDs around and you put it in a $2 enclosure? :rolleyes:
Sorry I didn't mention that I only used USB 2 enclosure to install Mountain Lion before I replace the HDD inside my mac. I have no intentions using a fast SSD on a crappy USB 2 enclosure.


Thank you for your input guys. Sorry I blamed my ssd where definitely there is nothing wrong with it.