VERY slow Time Capsule - Ideas?!

Discussion in 'Mac Accessories' started by callumuk, Apr 26, 2008.

  1. callumuk macrumors newbie

    Apr 26, 2008

    I've been using a 1Tb Time Capsule for a few weeks now, and have had nothing but trouble since I set it up. It's currently set up to join my home wireless network, which it does quite happily, but transferring files to or from it is painfully slow. The fastest it will go is about 1Mb/second (in either direction).

    I've tried both extending my current wireless network and asking Time Capsule to create its own wireless network. I then use my Macbook to access the files stored on the Time Capsule, and this is when things go downhill. I'm not trying to do anything complicated; just copy and paste files onto the device for backup purposes - but it still only goes at 1Mb/second, even when set to 802.11n speed. There are no other devices connecting to the network. Plugging in an Ethernet cable to do the file transfers increases the speeds, but completely defeats the object of having spent £300 (~$600!) on a device which is supposed to be able to do this wirelessly.

    Can anyone suggest what might be wrong? Is there any chance the device is faulty or am I just doing something wrong?
  2. merl1n macrumors 65816


    Mar 30, 2008
    New Jersey, USA
    It sounds as though you are using a router as a primary connection to the internet with Time Capsule as an add on to your network.

    First, check your settings on your primary router to see if it is setup to use 802.11n. If is is, it would still slow down access to your TC because your computer would first have to access the primary router, and then the TC.

    I would recommend that you swap the order of your devices. Make the TC your primary connection to the internet and your router as an extension of your wireless network. Then, your computer would connect directly to the TC, eliminating the overhead (and bottleneck) of your existing router.
  3. callumuk thread starter macrumors newbie

    Apr 26, 2008
    Thanks for the tip but I couldn't find a way to prevent the router from being the primary device on the network. Even if I could do that the speeds I'm currently getting are still far lower than they should be on a G network.

    Have you got any other suggestions?!
  4. laprej macrumors regular

    Oct 14, 2005
    Troy, NY
    Check the Apple forums

    Tons of people have been having issues with these. I know, because I own a TC and I've had my fair share of issues with mine. It's mostly straightened out now, though (cross my fingers)...

    A few things: make sure the name of both your computer and the TC is something short and simple: a single word (no weird chars) of 8 chars or less. I know it sounds crazy but I swear that was half my problem. Second, make sure your TC is on a "good" channel. Changing my channel from the 'automatic' setting (which seemed to consistently choose 11) to 6 nearly tripled my throughput. There's some other things you can try, but those should get you started. Like I said, read the Apple TC boards.

    Hope it helps.

  5. callumuk thread starter macrumors newbie

    Apr 26, 2008
    Thanks for the suggestion, but unfortunately this also hasn't worked. I've also asked on the apple forums and read plenty of other threads... still nothing!!

    Who would have thought this would be so much hassle?!
  6. nick9191 macrumors 68040

    Feb 17, 2008
    Lead paint? Thick walls? Anything which could stop the signal?
  7. callumuk thread starter macrumors newbie

    Apr 26, 2008
    hahaha..... Nah, same room, 5 metres apart. It's just refusing to behave
  8. merl1n macrumors 65816


    Mar 30, 2008
    New Jersey, USA
    In order to do this, you need to change your hookup physically as follows:

    DSL/Cable Modem -> wired TC -> wired Router.

    The TC should be setup to use DHCP from your DSL/Cable Modem.
    The router should be set with a static ip address within the same subnet as your TC.


    Your DSL/Cable modem assigns a network address to your TC like (This is your WAN address)

    Your TC itself for your LAN has an address of

    You configure your Router to use a static ip of, netmask, Gateway (your TC)

    Now you setup your Macbook (make another location) to use another static ip as such to connect directly to your TC

    Airport TCP/IP tab
    Configure "Manually"
    IP Address:
    Router/Gateway: (TC)

    Thus you are connecting directly to the TC without the overhead of the Router. You can have your other devices connect to the Router, but this way having your Macbook connect to the TC directly, let's you use 802.11n.

    You may also try the other suggestions as trying different wireless channels to see which is best. Also, if you have a cordless phone in the room, make sure it doesn't use the 2.4GHZ range as this will interfere with the wireless signals in both the router and TC. (I ran into this issue myself and changed my phone to 5.8GHZ model.
  9. sunracer macrumors newbie

    Apr 27, 2008
    I'm having the same problem...seeing about 5MB/s on my new 1TB TC. In my case, however, I have the wireless in the TC turned-off as it's not needed. The single machine I'm trying to backup with TimeMachine is connected to the same GigE switch as the TC (both are wired connections) and I routinely get ~117 MB/s between different (Windows) machines ont he same network although none are turned-on right now.

    All I really want is to use the TC as a wired network drive - no wireless at all and my internet connection is alrady taken car of (no TC required for that). ANy ideas on why the TC perf is so bad?...
  10. Zwhaler macrumors 604


    Jun 10, 2006
    I'm currently syncing 3 macs to my new Time Capsule and it is only going 0.1mb every 5 seconds. Be happy :p Hopefully it will speed up when it finishes up the initial backup
  11. sunracer macrumors newbie

    Apr 27, 2008
    wow...I can't see how less than a MB/s is even useable on a 1TB backup device - esepcially not a CDP mechanism like Time Machine. The problem I'm concerned with is that I have 700GB of data and as I move stuff around and reorg it I might change the file system by 10-50GB in a matter of minutes. Since TM isn't smart enough to know that I'v only move files it goes ahead and re-copies them to the backup device. And yes this is the reason that I also have a 2.8TB Drobo unit as well.

    The problem is simple, if the TC can't accept more than about 10-20GB /hr then what happens to my hourly backups if I change the file system by say 50GB in an hour. Basically, even based on my performance numbers (which appear to be very good compared to most) a 1TB TC is a useless product unless you plan to backup several clients to a single device where presumably not much data would change each hour.

    I've been unable to get any Windows shares working as a backup target although getting an Apple share from my G5 working was very easy.

    BTW, I just checked and my TC so far (after 550GB) has averaged 8MB/s although my traffic meter says that it peaked at 59MB/s so I need to figure out why the huge disparity.
  12. Takeo macrumors 6502a

    Nov 10, 2004
    I have a 1TB TC connected directly to a new iMac with a Cat6 ethernet cable and when transferring files I get at the most, 14MB/Sec. Nowhere close to Gigabit Ethernet's theoretical max of 120MB/Sec. Pretty pathetic. I'm thinking since I'm only backing up one machine, that I might just switch to an external USB hard drive. I did that initially actually (a 1TB Lacie)... but that Lacie drive gave me nothing but pain (locking up the Finder, not remounting on wake from sleep, etc.). I switched to the TC because I figured it would "just work". Well... it does... but it's soooooooooooooooooo slow.
  13. someara macrumors newbie

    Nov 19, 2008
    tcp settings

    A quick tcpdump says that it's using ipv6 to communicate to tc by default.

    If you go into your network settings and turn ipv6 off it goes a lot faster, but it's still not nearly as quick as it should.

    You can also:
    sudo sysctl -w net.inet.tcp.delayed_ack=0
    sudo sysctl -w net.inet.tcp.rfc1323=0
    sudo sysctl -w net.inet.tcp.recvspace=40960

    To make it permanent, stick this in /etc/sysctl.conf:

    For the curious:

  14. altaskier macrumors newbie

    Jul 11, 2008

Share This Page