Very slow transfer speeds with external hard drives through Firewire and USB

Discussion in 'Mac Pro' started by stridor, Nov 30, 2008.

  1. stridor macrumors newbie

    Nov 6, 2008
    Hi All,

    My external drives transfer very slowly on my MacPro. I've been searching for answers and have turned up very little. Apple support wasn't much help they just suggested I post my problem on a couple of forums! :confused:

    Just to make a note, I measured my disk speeds with both AJA System Test and copying files between drives and reading the Disk Activity in Activity Monitor.

    I have 3 external drives, all MyBook Premium or Professional, 1x 500GB, 1x 1TB and 2x 1TB in RAID 0. I had them on Firewire 400 and the RAID 0 2TB one on Firewire 800. My transfers on FW were all around 24MB/sec on all drives (much less than what I should be getting with FW400). I then read somewhere that the FW bus on the MacPro uses the slowest speed connected for all FW connections. So I unplugged everything but the FW800 Raid 0 drive and my transfer rate jumped to 40-60MB/sec. This is much better, but still about half or so of what I expect it should be producing from an external RAID 0 setup.

    To keep my FW800 backup drive faster, I've plugged the other two into USB2.0. The transfer speeds on both drives are now hideous, around 10-15MB/sec. This is so slow, but I'm not sure what to try to fix my speeds.

    The HD's in the external drives are all 7200rpm, and all should be transferring at a higher rate. Do you have any suggestions or ideas? Ideally I'd like to get everything transferring at rates they should be transferring at, but I'll settle with my current FW800 speed of 40-60MB/sec if I can get my other two drives transferring at a non-snail pace.

    Is this a common issue? I can't believe I'm the only one plugging multiple external hard drives into their Mac Pro. I hope someone has a fix or solution for this. I'm all ears! [​IMG]

    Thanks in advance.

    System: Mac Pro (early 2008) Mac OS X (10.5.5) 3.2Ghz 8-core - 16GB Ram - 4x1TB SATA - GeForce 8800GT - Dell 30" 3008WFP A02 - Gateway 21" FPD2185W - 3xMyBook external drives
  2. sickmacdoc macrumors 68020


    Jun 14, 2008
    New Hampshire
    Well my first question would be is how are the drives formatted, and what type of partition map are they using? Since MyBooks come formatted for Windows (some Editions as FAT 32 and some as NTFS which you would not be able to write to) with an MBR partition type to match, I have to wonder.

    Now don't get me wrong- that should not cause that much of a slowdown but it can contribute to it so thought I would ask.
  3. stridor thread starter macrumors newbie

    Nov 6, 2008
    All three have been formatted to Mac OS Extended (Journaled).

  4. Earl Urly macrumors regular

    Jul 11, 2004
    Try disabling journaling with Disk Utility and use Spotless to disable Spotlight indexing on the drive
  5. shroud macrumors member

    Sep 24, 2007
    I had the same problem (of many with my Mac Pro). The only way for me to fix it reliably was to install pci usb/firewire cards with independently powered ports. Apple was not going to help me on this issue. I chose sonnet but any should work. You may end up with sleep issues if you go this route, even with leopard.

    Prior to buying the cards, one thing that helped was that I unplugged my iSight from my Cinema display. iSight = trouble on a Mac Pro because of the power draw, even when not on but just plugged in.

    I don't know if you have any items that may be drawing power off of the ports on the tower but if you do then you should get powered hubs or pci-e cards rather than use the Mac Pro's ports. The design is not quite up to snuff regarding bus power draw and reliability on it.

    I have also read (can't remember where off hand) that the cinema displays themselves can cause issues when plugged into the tower using their firewire and usb cables. I am not sure if something had to be plugged into the cinema display as well or if it was just interference coming from the hub in the display.

    Other than this, maybe try out different cables as come cables are inferior to others; techtool pro, reset smc and p ram...Apple store if need be but they did nothing for me.
  6. stridor thread starter macrumors newbie

    Nov 6, 2008
    Does Journaling slow things down?
  7. stridor thread starter macrumors newbie

    Nov 6, 2008
    Thanks shroud for all that info!

    I managed to improve my performance a tad, but really not what I was hoping for. I may end up going down the route of an PCIe Firewire card, but I'll see if I can live with this for now.

    I posted this same question in the apple forums and a guy to post my speeds from xbench. After I did so he said my speeds looked like they were in the normal range.. I find that hard to believe but perhaps some of the transfer speeds I've read with various drives had put my expectations to high?

    Here's a repost of my current speeds and what I changed.

    So I rejigged my setup a tad. My RAID 0 is still FW800, the second drive is back on FW400 on the back port, and the third is USB 2.0 on the back as well.

    It's interesting to note that I saw the FW800 taking a bandwidth hit if the FW400 drives was being read/written to. For example, if I was averaging 50-60MB/sec on the FW800 drives and copy something large to the FW400 drive, each drive averages out to about 30/MB second, roughly half the FW800 speed I was getting. The USB while the slowest didn't cause any slowness on the FW drives.

    Here are my Xbench results. These results are from each drive being benchmarked individually with no other drives being tested at the same time.

    MyBook 2TB in a RAID 0 configuration: Firewire 800

    Results 75.42
    System Info
    Xbench Version 1.3
    System Version 10.5.5 (9F33)
    Physical RAM 16384 MB
    Model MacPro3,1
    Drive Type WD My Book
    Disk Test 75.42
    Sequential 80.92
    Uncached Write 69.16 42.46 MB/sec 4K blocks
    Uncached Write 110.79 62.68 MB/sec 256K blocks
    Uncached Read 53.66 15.70 MB/sec 4K blocks
    Uncached Read 136.76 68.73 MB/sec 256K blocks
    Random 70.62
    Uncached Write 36.38 3.85 MB/sec 4K blocks
    Uncached Write 140.55 45.00 MB/sec 256K blocks
    Uncached Read 93.26 0.66 MB/sec 4K blocks
    Uncached Read 88.38 16.40 MB/sec 256K blocks

    MyBook 1TB on Firewire 400

    Results 47.73
    System Info
    Xbench Version 1.3
    System Version 10.5.5 (9F33)
    Physical RAM 16384 MB
    Model MacPro3,1
    Drive Type WD My Book
    Disk Test 47.73
    Sequential 52.47
    Uncached Write 48.45 29.74 MB/sec 4K blocks
    Uncached Write 53.76 30.42 MB/sec 256K blocks
    Uncached Read 43.69 12.79 MB/sec 4K blocks
    Uncached Read 70.91 35.64 MB/sec 256K blocks
    Random 43.78
    Uncached Write 17.29 1.83 MB/sec 4K blocks
    Uncached Write 98.83 31.64 MB/sec 256K blocks
    Uncached Read 76.33 0.54 MB/sec 4K blocks
    Uncached Read 97.01 18.00 MB/sec 256K blocks

    MyBook 500GB on USB 2.0

    Results 40.60
    System Info
    Xbench Version 1.3
    System Version 10.5.5 (9F33)
    Physical RAM 16384 MB
    Model MacPro3,1
    Drive Type WD 5000AA External
    Disk Test 40.60
    Sequential 35.99
    Uncached Write 37.31 22.91 MB/sec 4K blocks
    Uncached Write 37.22 21.06 MB/sec 256K blocks
    Uncached Read 26.62 7.79 MB/sec 4K blocks
    Uncached Read 50.27 25.27 MB/sec 256K blocks
    Random 46.55
    Uncached Write 20.37 2.16 MB/sec 4K blocks
    Uncached Write 68.44 21.91 MB/sec 256K blocks
    Uncached Read 93.55 0.66 MB/sec 4K blocks
    Uncached Read 86.71 16.09 MB/sec 256K blocks

    Does this look normal to you guys?

  8. aralston macrumors newbie

    Dec 2, 2008
    Similar Problem on iMac G5

    I recently ran into a similar problem with my iMac G5. I have been running for months without any trouble with a single WD 240 GB drive in a Newer Technology IDE enclosure, and a Newer Technology v2.5 500 GB drive for Time Machine, both on a FW chain. I don't have anything else on the FW chain. Both drives are formatted Mac OS Extended (Journaled).

    I recently attempted to upgrade the 500GB drive to a WD 1TB. The WD drive (a refurb) had trouble, so I had to send it back and put the 500 GB drive back in. Coincidentally (??), I found I am having *very* slow transfer rates, but I can't be sure the trouble started with the swap-out. I have not run a benchmark yet, but it took about 18 hours to move about 10 GB of data (~150 kB/s :eek:) to the 500 GB drive with Spotlight indexing of the drive disabled. When I have more time I am going to systematically debug the problem, but if anyone has any advance pointers, I would be grateful.
  9. herbaliser macrumors newbie

    Dec 31, 2008
    this worked for me

    Not sure this will help stridor, but it worked for me : I unplugged my isight from my 23" cinema display...
    Thanks Shroud!
    Not sure how to measure the speed, but copying from an internal drive to an external firewire 800 drive is visibly twice as fast!
    Happy new year

Share This Page