Very Slow Wireless Data Transfer on Mac Book Pro

Discussion in 'Mac Basics and Help' started by zdoo01, Feb 13, 2008.

  1. zdoo01 macrumors newbie

    Joined:
    Feb 13, 2008
    #1
    First things first, I am running a Mac Book Pro with Leopard 10.5.2, my Wireless Router is a Linksys WRT300N and I have a 1TB lacie Ethernet big disc connected via Ethernet to the router. When I try and access files from the hard drive or from the desktop PC (running XP) that is also connected to the router it transfers files extremely slow. A 90mb file takes approximately an hour to transfer.

    I am a Uni student who was recently living with my parents of the Christmas holidays, I purchased the Ethernet hard drive while at home and plugged it into my parents Linksys Wireless g router and could get normal transfer rates without any difficulty. Since using my new wireless router at Uni it is ridiculously slow. Although if I boot my mac into Vista via bootcamp the wireless transfer rate is regular speed, it is also regular speed if I plug an Ethernet cable directly into the Mac. The internet connection is running perfectly, it is just data transfer that is particularly slow. It recognizes the hard drive and shared folders, but takes forever to transfer files from them.

    My basic wireless settings are
    Network Mode: Mixed
    Radio Band: Wide -40MHz Channel
    Wide Channel: 3
    Standard Channel: 5 - 2.432Ghz
    Wireless SSID Broadcast: Enabled

    On the Mac network Utility the Interface Information comes up as
    Link Speed: 130 Mbits/s
    Link Status: Active
    Vendor: Apple
    Model: Wireless Network Adapter (802.11 a/b/g/n)
    and when transferring files no send or recv errors come up.

    I am getting full wireless reception via airport
    The network is WEP Password encrypted.

    I don't know what else to try but would love to get my network working like it used to at home.

    Thanking you
    Jono Sumner
     
  2. ciphex macrumors newbie

    Joined:
    Jul 17, 2003
    Location:
    US
    #2
    Change Wireless mode

    I know this is a little old but...

    Two things,

    First:
    Try changing the Wireless Channel the router is operating on. Often high noise on a particular channel can interfere in a horrible way with certain AirPort cards/drivers, even when other wireless devices seem to work fine.

    Second:
    if the MacBook Pro is the only wireless device using the router, you might consider switching the router to N-only mode. MBPs have wireless N cards that support much faster data rates, it may be having trouble negotiating the protocol in Mixed mode. Of course this means that any a/b/g devices that try to use it would fail. Maybe that is a good thing?


    Beyond this, there are known issues with Leopard wireless performance that we all dearly hope will be addressed when 10.5.3 hits SOMETIME this month.
     
  3. zdoo01 thread starter macrumors newbie

    Joined:
    Feb 13, 2008
    #3
    Thanks. I'll give the first one a go when I get home. Lots of other devices on the network though.
    Thanks for the help!
     

Share This Page