Very strange bug appeared out of nowhere!

Discussion in 'macOS' started by Somebee, Feb 5, 2008.

  1. Somebee macrumors newbie

    Joined:
    Nov 9, 2006
    #1
    Hi. I've been running Leopard happily for a few months. Today I encountered a strange bug. All the "circles" with numbers in are larger than before, and I can't make bold text with command+b in any cocoa-application.

    Hard to explain, so I've attached some pictures:
    [​IMG]

    [​IMG]

    [​IMG]

    I'm not sure that these two are related, but they started at the same time. Anyone know what it might be? I've tried restarting, did not help.
     
  2. mkrishnan Moderator emeritus

    mkrishnan

    Joined:
    Jan 9, 2004
    Location:
    Grand Rapids, MI, USA
    #2
    Corrupted system font? Perhaps try font book and test to see if it finds any fonts wonky....
     
  3. Somebee thread starter macrumors newbie

    Joined:
    Nov 9, 2006
    #3
    Which fonts might it be? And how would I check if they are corrupted? Just replace the fontfiles with backups (has another leopard-install on an external drive), and then restart?
     
  4. mkrishnan Moderator emeritus

    mkrishnan

    Joined:
    Jan 9, 2004
    Location:
    Grand Rapids, MI, USA
    #4
    I think the program Font Book (in your Apps or Utilities folder?) can test them for you. But yeah, I guess you could just re-install them and reboot...

    The other thing to try is to temporarily create a new user account (you can delete it later) and log into that account. If you don't have this behavior there, then it's some corrupted user preference or something like that, and not a system resource like a font.
     
  5. ThomasShaped macrumors regular

    Joined:
    Jun 14, 2007
    Location:
    Glasgow
    #5
    I have that exact same problem! It started a few days ago out of nowhere and I don't know what to do about it. It's quite ugly.
     

Share This Page