Very strange Finder Issue, can't open programs - PLEASE help!

Discussion in 'OS X Yosemite (10.10)' started by LRock, Nov 30, 2014.

  1. LRock, Nov 30, 2014
    Last edited: Nov 30, 2014

    LRock macrumors newbie

    Joined:
    Nov 30, 2014
    #1
    Hello, I seem to have an odd issue. Not sure anyone is having the exact same problem. I do happen to have adobe CC products installed by the way.
    Anyway, it is showing that the finder is always active. You can see as it has that black dot under it in the dock. I can open new finder windows and also open google chrome, but the odd thing is, I can't open certain programs. Chrome and finder and system preferences will open, but I can't open the terminal, mail, safari, app store, Preview and other apple programs. I can't even open "about this mac" when I click on the apple icon. When I click on a program in the dock, it shows the icon bounce and there is a blink on the screen, but the program never opens.
    This is pretty much rendering my computer useless.
    I already fixed disk permissions. I tried to remove the com.apple.finder.plist file, but I can't find it. The library folder is under my HD and not under my user name. I'm not sure that is normal. I also created a new user account, but it is behaving the same way.
    Does anyone have this same issue? I have spent hours googling and nobody seems to have this same exact issue. I appreciate any help. Thanks!

    Here you can see the finder window is active, but there is no finder window:
    [​IMG]
     
  2. LRock thread starter macrumors newbie

    Joined:
    Nov 30, 2014
    #2
    Doing more research...

    Upon doing more research, looks like it is a known problem called Flashback malware (https://discussions.apple.com/thread/6637927?start=0&tstart=0). I am looking into a fix still. I may have to reinstall Yosemite but trying to avoid if I can.

    ----------

    OK I did a check and even though I have all the same symptoms, the tool says I do not have flashback malware. Not sure what to do, but if anyone has any clue please chime in. :(
     
  3. LRock thread starter macrumors newbie

    Joined:
    Nov 30, 2014
    #3
    Solved!

    Problem solved!
    Do not use CleanmyMac or other cleaning utilities! It removes necessary system files. Solution was to reinstall the OS.
     

Share This Page