VERY strange Kernel_task behaviour

Discussion in 'Mac Basics and Help' started by sandro123, Aug 16, 2008.

  1. sandro123 macrumors newbie

    Joined:
    Aug 16, 2008
    #1
    Hi guys,
    I recently moved to a Macbook running Leopard (10.5.4) and had this very weird behavior a couple of times, without being able to reproduce it.
    It happened that after using Itunes for some time, say 1 hour, the kernel_task was going mad, picking from -880 to 3,2400 (yes, I'm serious), with all other processes behaving as normal. I shut down every running program, but this didn't affect anything. At the end, I discovered that unplugging the headphones would bring everything to normal, and plugging it again would trigger the bizarre behaviour of kernel_task. I've checked Console messages, but nothing relevant there. The weirdest fact is that after a while, say 30 min., everything was ok again. I'm now trying to run Itunes again, and see what happens. I kinda suspect is something hardware, more than software.
    Any idea about it?
    Thanks in advance for your help,

    Sandro
     
  2. MorzillA macrumors 6502

    MorzillA

    Joined:
    May 16, 2007
    Location:
    Miami
    #2
    have u tried a diff. set o' headphones?! I made the stupid purchase of some GE headphones/mic (cheap) that are not compatible with my Mini, but works wonders with G/F's Acer laptop (vista basic crap edition). I have not tried with my G4 yet, also try some speakers and see if that too affects your MBP.



    :apple:
     
  3. sandro123 thread starter macrumors newbie

    Joined:
    Aug 16, 2008
    #3
    Yes, I tried with two different set of headphones, and with some speakers, but it was the same. The weirdest thing is that I'm not able to reproduce it, but it happened three times in 4 days. Now, for instance, Itunes is playing and everything's fine.
     
  4. sandro123 thread starter macrumors newbie

    Joined:
    Aug 16, 2008
    #4
    Ok, now Itunes finished its list, I minimized it and here's the problem again. Quitting Itunes doesn't change anything.
     
  5. sandro123 thread starter macrumors newbie

    Joined:
    Aug 16, 2008
    #5
    Ok guys, some (weird) news. If I play something in Itunes while the kernel_task is going crazy, it works perfectly. If I hit pause, the problem is there again (with the headphones plugged in). Also, I've open an avi file with VLC, and for the first few seconds there was no audio, then audio came back, and the kernel_task went down to normal levels.
    Can it be a bug with the audio management in Leopard?
     

Share This Page