VERY strange port 80 issue

Discussion in 'macOS' started by johncogan, Mar 6, 2012.

  1. johncogan macrumors newbie

    Joined:
    Oct 20, 2011
    #1
    Hi all

    I am getting a very strange issue with my Mac Desktop (Lion OS X).

    I can FTP, use skype and view HTTPS pages no problem. But if I try view a website I simply get Firefox/Safari giving my the "Connecting to..." and the busy icon. Does absolutely nothing beyond that.

    Strangely I CAN reach www.google.com and search for websites, but clicking any of the results gets me nowhere.

    My Mac is connected to my Vista PC via a Router. The Vista PC is sharing its 3G USB modems connection.

    I have another Windows 7 PC connected via the router as well. Both Windows machines have no issue browsing.

    MAC is DHCP, Windows 7 is DHCP and Vista PC (Internet connection PC) is setup with static IP.

    No firewalls running.

    Using Network utility on Mac to ping www.apple.com returns results.

    MAC can see shares on Windows system no problem.

    Lion server is running with Web Server on (For local site development). Oddly the main Lion Server website seems to say "Mac.local" and below that the folder points to "var/empty", not sure if this is relevant.

    Didnt install any software on any machines and this waas working fine the night before. This morning when I turned on the pcs and mac is when it all started.

    Any ideas what I can try please to try sort this.

    I have already tried:

    Reboot of machines.
    Trying macs ethernet in different router port.
    Renewing DHCP licenses on mac.

    Many thanks
    John
     
  2. r0k macrumors 68040

    r0k

    Joined:
    Mar 3, 2008
    Location:
    Detroit
    #2
    Clearly your internet is sort of working. You can reach google. The issue appears to be reaching anything else besides google.

    Sometimes success reaching one site followed by timeouts on other sites is a DNS issue. Try overriding and putting opendns or googledns entries in for your Mac (in properties tcpip for the ethernet) rather than letting the pc autoassign dns via dhcp. Then you should not only be able to reach google, you should be able to reach any link that google sends you to.
     
  3. johncogan thread starter macrumors newbie

    Joined:
    Oct 20, 2011
    #3
    Hi r0k, appreciate the tips.

    I have added 8.8.8.8 and 8.8.4.4 to the DNS server listings in the ethernet advanced tab of the Mac and still no such luck.

    I them did tracert on 8.8.8.8 and got a correct lsiting of results from that.

    Then tried "dig @8.8.8.8 hostname" in terminal and got the following, although I am unsure if its correct or not.

    ==============================================
    ; <<>> DiG 9.7.3-P3 <<>> @8.8.8.8 hostname
    ; (1 server found)
    ;; global options: +cmd
    ;; Got answer:
    ;; ->>HEADER<<- opcode: QUERY, status: NXDOMAIN, id: 57977
    ;; flags: qr rd ra; QUERY: 1, ANSWER: 0, AUTHORITY: 1, ADDITIONAL: 0

    ;; QUESTION SECTION:
    ;hostname. IN A

    ;; AUTHORITY SECTION:
    . 1800 IN SOA a.root-servers.net. nstld.verisign-grs.com. 2012030601 1800 900 604800 86400

    ;; Query time: 548 msec
    ;; SERVER: 8.8.8.8#53(8.8.8.8)
    ;; WHEN: Tue Mar 6 21:51:44 2012
    ;; MSG SIZE rcvd: 101
    ==============================================

    Really at my wits end.
     
  4. johncogan thread starter macrumors newbie

    Joined:
    Oct 20, 2011
    #4
    Slight error in original post

    I said I could reach google and search. But I have only just realised when I type "www.google.com" it accesses google using HTTPS automatically in Firefox

    As I can reach https on anything serving SSL this then means port 80 it not working at all.
     
  5. apowell macrumors newbie

    Joined:
    Nov 6, 2013
    #5
    Any Luck??

    I am experiencing exactly this. Everything but port 80 (http) is good. https, FTP, ping...

    Did you figure out how to fix it?

    Thank you.
     

Share This Page