Very stubborn disc, cannot eject!

Discussion in 'iMac' started by mattluc, Nov 1, 2009.

  1. mattluc macrumors member

    Joined:
    Oct 28, 2008
    Location:
    York, PA
    #1
    I'm using a 20" white intel iMac and cannot manage to remove a linux boot disc from the optical drive.

    At first, the only way that i managed to boot to the linux disc in the first place was from the Startup Disk menu in OSX. I could not even get to the Startup Manager ('opt' at boot) or boot straight to the disc ('C').

    Now i'm in a position where no matter what i do, the system boots to the linux disc. I cannot even force the startup into OSX to try to eject the disc from there. I've tried holding all of these keys/combinations at startup:

    eject
    mouse button
    f12
    d
    x
    cmd-x
    cmd-opt-p-r (in hopes of resetting the startup disc in the EFI, but i don't ever hear the two beeps that i think i'm supposed to)
    cmd-opt-n-v
    t (i can't even boot as a target disc!)

    I've also tried to see if the disc tries to eject but the piece of metal that closes off the slot never even tries to get out of the way to prepare the disc for ejection.

    Any other ideas?
     
  2. mattluc thread starter macrumors member

    Joined:
    Oct 28, 2008
    Location:
    York, PA
    #2
    I'm realized that the system isn't receiving input from the [brand new] keyboard. I've tried it in different usb ports. I'd try a different keyboard, but i don't have one.

    Solved! I plugged the mouse directly into the iMac (instead of through the keyboard) and the mouse button trick worked!

    Only now i have a "no bootable device" message. Ouch. Unrelated, though.
     
  3. sharkync macrumors regular

    Joined:
    Aug 8, 2009
    Location:
    Raleigh
    #3
    Thanks for posting your solution - nice thing to know.
     
  4. akm3 macrumors 68020

    Joined:
    Nov 15, 2007
    #4
    I'm glad you solved. In cases when I've had this problem, the thing that always worked for me was to drop to terminal and type
    drutil tray eject (There might be a hyphen in there somewhere)
     

Share This Page