Vibe Duo

Discussion in 'iPhone Accessories' started by brentg33, Nov 14, 2008.

  1. brentg33 macrumors 6502a

    Joined:
    Mar 5, 2007
    #1
    Hi, i have had a pair of vibe duos for my iphone for probably altleast a year now....earlier today, when i plugged them in i noticed the right ear woudl not work, turning the jack in the iphone resulted in some static and intermintent sounds but it quickly stopped. I then tried the stock apple ear buds and they seem to have no issues. i suppose it safe to say its the vibes are bad...but is there anything to do to fix them or are they done?
     
  2. Italchef macrumors 6502

    Joined:
    Nov 3, 2003
    Location:
    Maple, Ontario
    #2
    I'm sorry to say but from what I've read in reviews and in the forums, I'd say that they're toast and you're SOL. You could try contacting them and see if they would do anything about a repair/replacement.
     
  3. dlbernau macrumors newbie

    Joined:
    Aug 9, 2008
    #3
    try

    calling or emailing customer service-I have found them to be very helpful.
     
  4. jarofclay73 macrumors regular

    jarofclay73

    Joined:
    Nov 15, 2008
    Location:
    Honolulu, Hawaii
    #4
    Yeah from what I've heard you'll have to send them in.
     
  5. Smog macrumors regular

    Joined:
    Nov 2, 2007
    #5
    contatc v-moda about the problem. they will replace them for you as it is a manufactering fault. they have since updated the vibe duo's with a new headphone jack. Hope this helps.
     

Share This Page