Viber desktop for Mac OS keep crashing non stop

mightylover4

macrumors newbie
Original poster
May 22, 2013
2
0
Hi guys, I was wondering if anyone could help me with this Viber desktop on my imac.

It keep crashing all the time and will never stop. I have tried to delete/uninstall it and restart computer and restore it but as soon as I have restored it back, It doesn't start from like enter phone number and code and things like that but it opens up and trying to load/sync my texts and contact list and then Crash and give me this message:


Please help me, i really need this app on my imac.

Thanks in advance!
 

eattherich

macrumors 6502a
Jul 8, 2011
581
151
Berlin
Can you provide a little more information such as the specific model of iMac and the version of OS X you're running. Maybe this will help somebody provide better help. Have you looked on Viber's support page? There's an FAQ section and I believe they offer good support using Twitter so if you don't find an answer on here then I'm sure you can send Viber the information in the "Show Details" section of the problem report. Good luck. :)
 

mightylover4

macrumors newbie
Original poster
May 22, 2013
2
0
Hi I have an imac mid 2010 running on Mountain Lion 10.8.3. I have tried to facebook viber but got no replies. Thanks
 

webstarcool

macrumors member
Oct 27, 2010
84
36
SFO
Does the same on my computer. As soon as I send a message, Viber crashes and gives me the message that is has quit unexpectedly.

I'm using a MPB 2013, Maverick and the latest version of Viber.
 

imehran

macrumors newbie
Sep 22, 2014
1
0
Same Problem

Exactly same problem , i aslo Submitted ticket on viber but no answer till now !
 

kulorex

macrumors newbie
Oct 27, 2014
4
0
Same problem

I have a Mac book pro retina late 2012. I have been using viber for over a year now. Was using it on maverick for a long time. It works just fine. Then one day after a normal restart, I started experiencing this crashing problem. I tried uninstalling, reinstalling, nothing changed. I upgraded to Yosemite same thing. I recently did a clean upgrade to Yosemite, again same issue. Apparently, I notice that my modem app - Airtel Internet is also behaving the same way. Really frustrating as I heavily rely on these two apps.
Someone please help.
 
Last edited:

myrepospace

macrumors newbie
Feb 4, 2015
1
0
Found it

After 1 year of not using this damn app; I finally managed to get it to work for longer than 20 seconds.

1. Update to Version 5.0
2. Go to Preferences > Notifications > "Play Sounds For" > Calls Only

That fixed it for me.
Good luck to everyone.
 

vadik.l

macrumors newbie
Jul 16, 2014
3
0
I can't even start the app, it shoes in the dock and straight away disappears. Reinstall doesn't work. And I think it's related to the audio driver, I've switched from AppleHDA to VoodooHDA to be able to run audio via HDMI and after that Viber became mad :)
 
Register on MacRumors! This sidebar will go away, and you'll see fewer ads.