video cam not working after jailbreak

Discussion in 'Jailbreaks and iOS Hacks' started by blackred68, Aug 14, 2010.

  1. blackred68 macrumors newbie

    Joined:
    May 12, 2010
    #1
    Need help!!! iPhone 3GS, 32GB, iOS4, jailbroken(jailbreakme.com), unlocked(Ultrasnow) Everything was fine except when i used my iPhone video camera... IT DOES NOT WORK!!! The camera in taking up pictures works fine,,, but when i slide to video camera and push the center button to record,,, it just turns into gray(the photo in left side and the sign of camera and video cam in right side),, and doesn't move at all... PLEASE HELP ME ON HOW TO MAKE MY VIDEO CAMERA FUNCTION AGAIN... It stops working after i jailbreak and unlocked my iPhone... Im looking forward for the step by step way on how to solve this problem.... THANK YOU in advance...
     
  2. Intell macrumors P6

    Intell

    Joined:
    Jan 24, 2010
    Location:
    Inside
    #2
    I had this problem with my 3Gs on 3.1.3. I fixed mine by importing my Camera Roll with iPhoto and then deleting the DCIM folder using SSH. After I restarted my iPhone, everything worked again.
     
  3. blackred68 thread starter macrumors newbie

    Joined:
    May 12, 2010
    #3
    Where can i find iPhoto?? Sorry coz i dont have any idea.. And what is DCIM?? Im very sorry for knowing nothing about this... If you wont mind,,, It will be of great help if you can teach me the step by step details of doing this.. but if you dont have enough time Im still giving my thanks for spending your time about my problem... Many thanks!!!
     
  4. Intell macrumors P6

    Intell

    Joined:
    Jan 24, 2010
    Location:
    Inside
    #4
    First install and setup OpenSSH: http://www.iclarified.com/entry/index.php?enid=3221
    Install MobileTerminal for iOS 4: http://www.podzombie.com/2010/08/le...-v4-2-6-the-easy-way-ios4-compatible-version/
    Then change your root password: http://www.iclarified.com/entry/index.php?enid=5883
    Then plug your iPhone into your computer and import the pictures off of it (Vista/Win 7 how to ->): http://www.rickysays.com/copy-iphone-pictures-to-vista
    Then SSH into your iPhone and navigate to the \User\Media\DCIM\ folder and rename it DCIMOLD.
    Reboot your iPhone and sync your imported pictures back over using iTunes. This should get your video going again.
     
  5. blackred68 thread starter macrumors newbie

    Joined:
    May 12, 2010
    #5
    I will try to search about this by myself... may I ask you one last favor??? Will you tell me the meaning of DCIM??? for me to know what exactly to search for... or is there anybody who can teach me the meaning of DCIM??? Thank you again....
     
  6. blackred68 thread starter macrumors newbie

    Joined:
    May 12, 2010
    #6
    WOW!!!! I really appreciate this... THANK YOU VERY MUCH, I'll try my very best to be successful in doing this...
     
  7. Intell macrumors P6

    Intell

    Joined:
    Jan 24, 2010
    Location:
    Inside
    #7
    DCIM is the name of the folder you have to rename so iOS will make a new one that isn't plagued by the video recording problems. See my above post on how to fix it.
     
  8. blackred68 thread starter macrumors newbie

    Joined:
    May 12, 2010
    #8
    Hi Intell,
    I'm almost done except on how to SSH into iPhone and navigate to the /User/Media/DCIM/ folder and rename it to DCIMOLD.
    I hope you are still there for me. I've tried many times doing this, but I cant do this..Dont know how to do this.... will you please lead me the way... pleaseee....Thank you....
     
  9. Intell macrumors P6

    Intell

    Joined:
    Jan 24, 2010
    Location:
    Inside
    #9
    I'll be away most of today, but I'll still try to help, via iPhone. Are you on Windows or Mac?
     
  10. blackred68 thread starter macrumors newbie

    Joined:
    May 12, 2010
    #10
    Im using Windows 7. I think theres something wrong in my computer... Im in the feeling of giving up this time...

    Thanks for your kindness! It seems that you are so busy in your activities,,, and I dont want to disturb anymore,,,

    Many many thanks to you Intell,,, take care always......byeee...

    More power to you...
     
  11. H22artman macrumors newbie

    Joined:
    Mar 6, 2011
    #11
    Sorry to revive such an old topic, but I have recently been experiencing the same problems.

    I tried the fix described above to no avail. I restored and rebroke my phone and the problem went away but only temporarily. This is really bugging me cause I can't take videos of my daughter.

    Any further help would be greatly appreciated.
     

Share This Page