Become a MacRumors Supporter for $50/year with no ads, ability to filter front page stories, and private forums.


macrumors 6502a
Original poster
Nov 29, 2004
Toronto, ON
I've been fighting this one for a few weeks, and need some help.

I have a Macbook Pro Mid 2009 w 3.06 Ghz Core2Duo. Back in June, I upgraded the RAM to 8GB, installed a 256GB SSD in the DVD drive bay with a fresh copy of Mavericks, while leaving the original 512GB HD in the original slot, running DP Yosemite. Ran fine.

Then, watching a Youtube video in Mavericks, the system would freeze, and tell me there was a Kernel Panic. And, typically after 2-40 minutes, stutter, I could repeat it. Tried a different browser, didn't matter. Alright, let's use the integrated card, instead of the dedicated graphics... no matter. Kernel Panic.
Close down all non OS programs (Aside from normal updates, I haven't installed any new software...) Boom... KP.

Netflix... Crash after 2-40 min of video, stutter, KP.

Go to \Library\Internet Plug-Ins\ and remove reference to anything but Java, Quartz and Quicktime. Remove all start on login programs. Remove any browser extensions. Again, same problem once the video codecs are installed and I watch video thru a browser after a bit. Sometimes after reboot, and 2 minutes playback, sometimes after an hour. It ONLY affects internet video playback. Everything else seems solid.

So, reboot in to Yosemite, and it is the same crash game again. Firefox, Chrome, Safari, doesn't matter.

Apple Hardware Test - Extensive - no issues found. Memtest - no issues found

This seems to be all I see, which doesn't tell me much, other than a memory page fault... I think:

Anonymous UUID: AE110BE0-722F-7B1A-72FA-83310C191C85

Sun Oct 12 12:35:09 2014
panic(cpu 1 caller 0xffffff801e2dc43e): Kernel trap at 0xffffff801e24b1ea, type 14=page fault, registers:
CR0: 0x000000008001003b, CR2: 0x0000017d8bba957e, CR3: 0x000000002101c000, CR4: 0x0000000000000660
RAX: 0xffffff80f9f45000, RBX: 0xffffff80f9f46950, RCX: 0xffffff8030ae4f78, RDX: 0xfffffe036e402e74
RSP: 0xffffff811fecbf40, RBP: 0xffffff811fecbf50, RSI: 0x0000017d8bba957e, RDI: 0xffffff80f9f46950
R8: 0x00000000e0000000, R9: 0x7ffffffffffffffe, R10: 0xffffff811fecbd00, R11: 0x0000000000000860
R12: 0xffffff80f9f46950, R13: 0xffffff8030ae4e30, R14: 0x0000017d8bba957e, R15: 0xffffff80f9f46960
RFL: 0x0000000000010082, RIP: 0xffffff801e24b1ea, CS: 0x0000000000000008, SS: 0x0000000000000010
Fault CR2: 0x0000017d8bba957e, Error code: 0x0000000000000002, Fault CPU: 0x1

Backtrace (CPU 1), Frame : Return Address
0xffffff811fecbbd0 : 0xffffff801e222f79
0xffffff811fecbc50 : 0xffffff801e2dc43e
0xffffff811fecbe20 : 0xffffff801e2f3976
0xffffff811fecbe40 : 0xffffff801e24b1ea
0xffffff811fecbf50 : 0xffffff801e2375c7
0xffffff811fecbf90 : 0xffffff801e2378d8
0xffffff811fecbfb0 : 0xffffff801e2d7607

BSD process name corresponding to current thread: kernel_task
Boot args: mbasd=1

Mac OS version:

Kernel version:
Darwin Kernel Version 13.4.0: Sun Aug 17 19:50:11 PDT 2014; root:xnu-2422.115.4~1/RELEASE_X86_64
Kernel UUID: 9477416E-7BCA-3679-AF97-E1EAAD3DD5A0
Kernel slide: 0x000000001e000000
Kernel text base: 0xffffff801e200000
System model name: MacBookPro5,3 (Mac-F22587C8)

System uptime in nanoseconds: 1638726909764
last loaded kext at 247254886053: 1.9 (addr 0xffffff7fa05e9000, size 65536)
last unloaded kext at 307771554992: 1.9 (addr 0xffffff7fa05e9000, size 57344)
loaded kexts: 1.9.5d0 3.0 1.60 4.2.7f3 100.14.34 3.11 124 2.6.3f4 2.0.4d1 2.6.3f4 1.0.0 3.5.13 1.7.0 8.2.4 4.2.7f3 1.0.0d1 7.0.0 1 3.6.22 1.2.5 3.0.4d1 240.2 240.2 325.7 1.0.0d1 1.0.0d1 1.0.0d1 35 3.4.1 404 2.6.0 700.20.22 5.0.2 683.4.0 3.0.5 2.0.21 656.4.1 660.4.0 2.0 1.8 161.0.0 2.0 2.1 2.0 1.7 217.92.1 153 3 217.92.1 1.0 10.0.7 3.6.22 2.6.3f4 1.0.0 1.9.7fc2 1.14 2.6.3f4 2.6.3f4 1.0.0 1.0.12d1 5.7.1d6 8.2.4 8.2.4 4.2.7f3 2.2.6 91.1 4.2.7f3 3.6.22 1.0.4 1.0.12d1 2.4.1 2.4.1 3.1.8 240.10 660.4.0 3.6.7 3.6.0 3.6.7 650.4.0 656.4.1 640.36 4.5.5 660.4.2 2.6.5 3.2 686.4.1 2.0 2.2.9 2.0 2.0.0 1.1 278.11.1 1.0.0d1 7 2 371.1 1.9 23 28.30 2.0 2.9 1.4 1.0 1
Model: MacBookPro5,3, BootROM MBP53.00AC.B03, 2 processors, Intel Core 2 Duo, 3.06 GHz, 8 GB, SMC 1.48f2
Graphics: NVIDIA GeForce 9400M, NVIDIA GeForce 9400M, PCI, 256 MB
Graphics: NVIDIA GeForce 9600M GT, NVIDIA GeForce 9600M GT, PCIe, 512 MB
Memory Module: BANK 0/DIMM0, 4 GB, DDR3, 1067 MHz, 0x0000, 0x484D54343531533641465236432D47372020
Memory Module: BANK 1/DIMM0, 4 GB, DDR3, 1067 MHz, 0x0000, 0x484D54343531533641465236432D47372020
AirPort: spairport_wireless_card_type_airport_extreme (0x14E4, 0x8D), Broadcom BCM43xx 1.0 (
Bluetooth: Version 4.2.7f3 14616, 3 services, 15 devices, 1 incoming serial ports
Network Service: Wi-Fi, AirPort, en1
Serial ATA Device: ST9500420ASG, 500.11 GB
Serial ATA Device: OWC Mercury Electra 3G SSD, 240.06 GB
USB Device: Built-in iSight
USB Device: Internal Memory Card Reader
USB Device: Apple Internal Keyboard / Trackpad
USB Device: IR Receiver
USB Device: BRCM2046 Hub
USB Device: Bluetooth USB Host Controller
Thunderbolt Bus:

I get this nagging feeling that a clean OS install isn't going to fix a thing, even though this appears to only be affected by browser video playback.

Suggestions welcome.


macrumors 68020
Aug 22, 2014
And this only happens in video? Never when not watching a video?
I used to have a random crashing problem just like yours; 8GB ram in Mid-2009 MBP. Turns out the 8GB RAM that was installed by the previous owner was defective.

Because it ONLY happens while watching video, I doubt it is ram, but it still may be. Use Apple hardware Test (extended tests) and/or Memtest86.


macrumors Core
Oct 14, 2008
Download any GPU benchmark program (Unigine Valley is a good choice) and run it for a while. Other then that, an extended memtest is in order. I think there are high chances that your RAM or VRAM are corrupt.


macrumors 604
Oct 24, 2013
Which SSD do you have??

I had this problem with a 3rd party ssd and mavericks in my old 2010, I rolled back to mountain lion, all good and it is still used by my brother every day.

My SSD is a renice 240gb a fantastic SSD just incompatable with mavericks...


macrumors G5
Jul 11, 2009
I get this nagging feeling that a clean OS install isn't going to fix a thing, even though this appears to only be affected by browser video playback.

Suggestions welcome.

There's nothing in the panic log to indicate that it's a graphics related issue even though it happens during video playback. Do you have any other applications on your computer that can load the CPU?
Do you have other RAM you can put in to test with? Even though memtest didn't find anything I wouldn't rule out memory errors.


macrumors 6502a
Original poster
Nov 29, 2004
Toronto, ON
Pt 2.

Well, I wiped the OWC SSD and installed a clean Yosemite OS.

Fired up Safari, downloaded Silverlight, got 3 minutes in to a show, and I got the panic again.

So, I'd assume that eliminates software as the issue. Trying to swap out the 8GB of RAM for the original 4GB this weekend, and see if that brings back some stability.


macrumors 6502a
Original poster
Nov 29, 2004
Toronto, ON
Replaced the RAM back to the original 4GB.

Machine seems a bit faster, and, no more crashing.

I'm still not sure why all of my memory tests seemed to be fine, but definitely the RAM was the issue. Might be RAM build quality, I'm not sure... it was a gift, and before installing, had never heard of DMS (
Register on MacRumors! This sidebar will go away, and you'll see fewer ads.