Video Drivers Help!

Discussion in 'Windows, Linux & Others on the Mac' started by bassrocker521, Jul 28, 2009.

  1. bassrocker521 macrumors newbie

    Joined:
    Jul 5, 2008
    #1
    I went onto the Nvidia site and downloaded what I thought to be the latest drivers for my 9400M (I have the 13" Unibody Macbook Pro). Unfortunately after restarting my computer the screen has gone to a wonky resolution and the colors look like something out of a DOS game. I can't find my Leopard Disk that has the drivers on it, does anyone have any suggestions on how to revert to my old drivers (there was no backup on the hard drive)?
     
  2. bassrocker521 thread starter macrumors newbie

    Joined:
    Jul 5, 2008
    #2
    Follow-up

    Well since no one answered me and google seems to fail me, I've simply reinstalled Windows XP. Can I use a friends 13.3" Polycarb restore disk for the drivers on this clean install?
     
  3. aki macrumors 6502a

    Joined:
    Mar 2, 2004
    Location:
    Japan
    #3
    im sure there are people with much better answers bit since none of them are here now

    first usually there is some option to rollback to prev driver in the video driver window... that didnt work right?

    anyway in my case i always use the dox modified drivers from laptopvideo2go . i know you just want to restore your old drivers not test out something all modded but actually the dox drivers are very good at least for me

    if you are at a deadend before reinstalling a whole OS you could try those

    good luck!
     

Share This Page