Video Playback Blocked?

Discussion in 'iPod touch' started by AppleRob., Dec 27, 2012.

  1. AppleRob. macrumors newbie

    Dec 27, 2012


    Now i won't go into details but i believe my ISP has somehow blocked video playback to my Jailbroken iPod Touch 4G after i have been watching some 'interesting' videos throughout the year.

    Whenever i attempt to play a video on my connection i receive a message telling me that the playback was unsuccessful, and sometimes the videos just sticks at the loading stage. This happens with any video you can possibly imagine. I've tried every app possible including YouTube, MXTube and TubePlayer but none of them work at all. It only happens with my connection at home, anywhere else i can watch videos as normal whenever i like.

    So i have looked in my iPod WiFi settings and discovered options such as DHCP, BootP, Static and then IP Address, Subnet Mask, Router, DNS, Search Domains, Client ID and also Renew Lease and HTTP Proxy.

    I'm only sixteen and although i am usually very good with technology i do not really understand the majority of these network options.

    To bypass the restrictions that the ISP has set (assuming it is them who are blocking my video playback) i think i will need to change my IP address or something like it, but saying that i have tried using a proxy server and i still can't watch or load any videos so i am quite confused.

    This only happens on my iPod which makes it even more odd.

    Help would be appreciated as always.

    Thanks, Rob.
  2. Plutonius macrumors 604


    Feb 22, 2003
    New Hampshire
    Sounds more like a router / Touch issue at home.
  3. AngerDanger macrumors 68040


    Dec 9, 2008
    Perhaps there is a conflict between a couple of tweaks you've recently installed. Have you tried watching videos after booting your iPod in safe mode? If you can get that to work, you'll know the issue is with your jailbreak and not a potentially invasive ISP.
  4. AppleRob. thread starter macrumors newbie

    Dec 27, 2012
    Good idea, i'll have a go now and see what happens.
  5. AngerDanger macrumors 68040


    Dec 9, 2008
    Cool. Be sure to keep us updated.
  6. AppleRob. thread starter macrumors newbie

    Dec 27, 2012

    You'll never guess what's happened...

    It turns out that the jailbreak was causing the issues after all. When i attempted to play a video in safe mode there were no problems whatsoever, so there must be a dodgy tweak in the system somewhere.

    These screenshots and lists below show all the packages i have installed, but none look like they would cause a problem with the video playback to me. Is there any way to sort these in order of installation/update?

    My Installed Packages


    And also: Zephyr, ZoomisBack! and BatteryDoctorPro.

    These are the tweaks which rely on Mobile Substrate. The others important ones i have which don't rely on it are: BytaFont, FreeMemory, Grooveshark, iBlank, iCleaner, IconMaker, Iconoclasm Layout Maker, iFile, iPod 720p Camera, MobileTerminal, MxTube, Remove Lauch Daemons (What's this?), Safe Mode Launcher and VLC Media Player.

    That's a lot isn't it. No wonder my RAM is always between 10 and 40MB!

    Thanks guys, hope you can help again.

  7. AngerDanger macrumors 68040


    Dec 9, 2008
    Alright, try removing ProTube 2 and MxTube. Perhaps one of those is causing a conflict, and the other is fine.
  8. AppleRob. thread starter macrumors newbie

    Dec 27, 2012
    Strangely, everything seems to have magically started working again before i could even remove those two. How odd.

    Thanks everyone, what a brilliant forum to get advice this is. :)

Share This Page