Video Viewing and Buffer problems on Macbook unibody

Discussion in 'Mac Basics and Help' started by ohserena, May 28, 2009.

  1. ohserena macrumors newbie

    Joined:
    May 28, 2009
    #1
    Hey I just got this macbook aluminum unibody it's only almost 6 months old. I got it from a friend in perfect condition with receipts and everything. This is my first mac ever and I love the way it works, except I have a few issues that I don't know how to deal with.

    He restored it to factory defaults for me and I installed ONLY aim, office, and firefox and updated Flash player to the latest version. I still have about 140+ gigs free and it has 2 gigs of RAM in it. I haven't even started to move my files from my old pc to the mac yet.

    When I tried to stream a video from hulu, it takes a few minutes to buffer fully and the video skips when it's buffering. It also buffers more than once during the course of 1 hour show. It did the same with a youtube video, it just skips. Somebody told me it has something to do with the speed of the internet and the speed of the computer? I'm not sure what that means or how to deal with it.

    Again, this is just streaming, not downloading movies or anything.

    Can someone help me out please?
     
  2. MarkMS macrumors 6502a

    Joined:
    Aug 30, 2006
    #2
    The new Macbooks are more than capable to play Youtube and Hulu videos. They can even play HD videos flawlessly, so I'm guessing the reason it keeps buffering is because of your internet.

    First, try running a speedtest for your internet. You might have a really slow connection and may need to talk to your ISP about upgrading. By the way, who is your internet service provider? Is the MacBook on WiFi? IF so, try to either get really close to the router (i.e., in the same room as the router) or use ethernet cable.
     
  3. ohserena thread starter macrumors newbie

    Joined:
    May 28, 2009
    #3
    Thanks a lot, I was just using wifi I guess that was it. I'll try the Ethernet connection and see what happens. I'll see about the speedtest too.

    Good to know what's going on, eventually I'll catch on.

    Thanks a lot!
     
  4. ohserena thread starter macrumors newbie

    Joined:
    May 28, 2009
    #4
    Well I'm at my macbook right now, and I was going to tried to connect to the ethernet connection I have in my apartment, but I can't do it! Now I'm getting frustrated. I have an internet connection I can't use because of some ip address situation and wireless connections that I can't fully take advantage of because of the speed of the laptop or the proximity to the router?

    I mean I thought the best thing about having a laptop was that you could hook up to the internet anywhere there was wifi and you were good to go. I don't know what to think now.

    I had a pc that connected fine to the same wireless connection and I also have a brand new Toshiba living in the other side of my apartment that has no issues with the wireless connection at all. It seems to be just my macbook that just I guess isn't getting enough signal to stream a simple hulu video.
     
  5. MarkMS macrumors 6502a

    Joined:
    Aug 30, 2006
    #5
    Ok never mind the ethernet. If your PC can stream videos fine from the wireless connection, then it's not the internet or router. It's got to be something with the MacBook and the only thing I can think of is updating to Flash 10. You've already done that, but go to Adobe's site and make sure there are no new updates.

    Also, are you using Safari to watch the videos? Try using another browser like Firefox and see if that helps.

    I'm really at a loss as to what could be causing your problems. Sorry I wasn't much help. Maybe someone else can offer other suggestions.
     
  6. d_saum macrumors 6502

    d_saum

    Joined:
    Jun 14, 2005
    Location:
    NC
    #6
    I have the same problem. When I watch videos from Youtube, and other streaming sites, my video lags every 10 or 15 seconds. It's not my internet speed as the vids buffer quickly, and I have the latest version of flash.

    So yeah, I think the OP and I have the same issue.
     
  7. ohserena thread starter macrumors newbie

    Joined:
    May 28, 2009
    #7
    Hey thanks for trying to help out. I already am using Firefox and I updated Flash. It still takes forever to buffer a video and it buffers a few times during an episode.

    I'm trying to update the software on the computer and that's proving problematic for me as well. I don't know how to manually install the software.

    I'd be happy if this streaming issue was fixed tho. Anybody who has an idea of what i can try is welcome to throw it out here.
     
  8. sukanas macrumors 6502a

    sukanas

    Joined:
    Nov 15, 2007
    #8
    i got this problem too on my unibody.. anyone got a solution?
    hulu/youtube runs perfectly fast on XP bootcamp and i clean installed SL
     
  9. sukanas macrumors 6502a

    sukanas

    Joined:
    Nov 15, 2007
  10. iluvrobots macrumors newbie

    iluvrobots

    Joined:
    Mar 17, 2007
    #11
    I Fixed It! Yay!

    I was having problems with buffering and slow load times on WiFi with a new pre-Fall '09 MacBook loaded with Snow Leopard. My top download speed was 9 mbps according to speedtest.net, which is the same on my old iMac that I didn't have any problems with. So I called our ISP and they weren't the problem. Then I considered that it was the modem/router or the channels I was using.

    In the end, this is what I think fixed it:
    - Deleting caches folder from library
    - Downloaded Snow Leopard Cache Cleaner
    - Checked for software updates
    - Restarted holding down the shift key (safe mode), log in as yourself and then restart again

    Before I couldn't get through an episode on Hulu without buffering every couple minutes :( and now I am having ZERO problems. And I am noticing a difference in my load times. I still have the same mbps but it works a thousand times better.
     

Share This Page