videos that won't play?

Discussion in 'Apple TV and Home Theater' started by suzerain, Sep 27, 2007.

  1. suzerain macrumors regular

    Joined:
    Oct 5, 2000
    Location:
    Beijing, China
    #1
    I have a weird situation on my Apple TV, and was wondering if anyone else had similar issues.

    Since I live in a country where I cannot get any western TV, the Apple TV has been an incredibly useful device for me. Usually I am converting from xvid AVIs to H.264 using the Elgato Turbo.264. I've never had any problem, except with one set of videos.

    Here's what happens: the files have been converted and play back in iTunes on my MacBook Pro fine. They get copied to the Apple TV fine. When I scroll the lists, I can see the preview image, and metadata for the file.

    Then, when you try to play it, there's a long pause, and then just an Apple logo. The question is: what would be the thing that makes files that can play on the computer, but not on the Apple TV? I was under the impression both were using QuickTime. Is it a matter of the dimensions of the video? Can the Apple TV not play back some sizes?

    Any insight would be appreciated...
     
  2. pavloskgr macrumors member

    Joined:
    Sep 6, 2006
    #2

    there are some video files that play in itunes but won't play on ATV! i remember , i had some .mov video files that ATV couldn't play them! What kind of video files are yours?(.mp4, .mov?)
     
  3. suzerain thread starter macrumors regular

    Joined:
    Oct 5, 2000
    Location:
    Beijing, China
    #3
    Mine are H.264 mp4 files.

    I tried encoding the same files with both El Gato Turbo.264 and Visual Hub, and...no love.

    It's the strangest thing; they play in the Finder, in iTunes, etc., but not on ATV. Just black screen, then Apple logo, then a long pause, and goes back to the menus; almost like the playback engine crashed or something.

    Some specs:

    H.264/AVC, 576 x 320, Millions
    AAC, Stéréo (G D), 48,000 Khz
    25 fps
    1327.38 kbits/s bitrate
     
  4. sWaltuo macrumors regular

    Joined:
    May 25, 2007
    #4
    Have you tried right clicking the file in iTunes and having iTunes "convert for appletv"?

    Might be worth a try ..
     
  5. pjarvi macrumors 65816

    pjarvi

    Joined:
    Jan 11, 2006
    Location:
    Round Lake, IL
    #5
    It could be the framerate. There's a Q/A in the faq for the ElGato Turbo encoder about videos causing the AppleTV to reset. Try changing the framerate setting in the encoder from automatic to 29.97.
     
  6. greacher macrumors newbie

    Joined:
    Jan 17, 2008
    #6
    apple tv specs

    Check the specs on your apple tv. I believe on this side of the water (NA) they only include MP4 support up to 24 fps. Might be the same for you.
     
  7. suzerain thread starter macrumors regular

    Joined:
    Oct 5, 2000
    Location:
    Beijing, China
    #7
    The answer:

    Hi there...thought I'd post the answer in case anyone else has this trouble.

    The videos in question were from the UK, and they were HD, and they were in PAL format.

    The solution is to convert them to be 23.976 frames per second. Apparently the Apple TV only supports HD at that frame rate, at least in this context.
     

Share This Page