VideoTutorialsRock OpenGL

Discussion in 'Mac Programming' started by Blakeasd, Nov 13, 2011.

  1. Blakeasd macrumors 6502a

    Joined:
    Dec 29, 2009
    #1
    Hello!
    I am following along with the Video Tutorials Rock OpenGL tutorials and I am having an issue with the Terrain tutorial. Whenever I run the program I get an "image not found error". I create the project by
    1) Creating a C++ Console Project

    2) Deleting the default main.cpp file

    3) Dragging in the files from the tutorial

    4) Adding OpenGL and GLUT

    The writer of the tutorial wrote a C++ image loader, so OpenGL can see the height map I am using.

    Here is the code in PasteBin:

    imageloader.cpp: http://pastebin.com/aHBAAMrY

    imageloader.h http://pastebin.com/NSdb2xHP

    main.cpp http://pastebin.com/QdwCuRZS

    I wish I could figure out the image loader code, but I only know Objectve-C and enough C++ to use OpenGL.. :D

    Thanks!
     
  2. jiminaus macrumors 65816

    jiminaus

    Joined:
    Dec 16, 2010
    Location:
    Sydney
  3. lloyddean macrumors 6502a

    Joined:
    May 10, 2009
    Location:
    Des Moines, WA
  4. Blakeasd thread starter macrumors 6502a

    Joined:
    Dec 29, 2009
  5. lloyddean macrumors 6502a

    Joined:
    May 10, 2009
    Location:
    Des Moines, WA
    #5
    Product Menu -> Edit Scheme
    View Tab -> Options
    Working Directory -> Use custom working directory

    Point to your projects supporting data folder!
     
  6. Blakeasd thread starter macrumors 6502a

    Joined:
    Dec 29, 2009

Share This Page