Viewing hidden files

Discussion in 'macOS' started by BadlyDrawnGirl, Jun 29, 2008.

  1. BadlyDrawnGirl macrumors member

    Joined:
    Aug 25, 2006
    Location:
    New Zealand
    #1
    Hi guys...I am trying to get my iBook to display hidden files and folders, which I am using the following command for in Terminal:

    defaults write com.apple.finder AppleShowAllFiles TRUE

    The message that comes up when I try this is "Command not recognized." The only problem I can think of is that I don't have Internet access at home at the moment, but I have no idea why that would make any difference. Does this mean that I need to reinstall my OS or something?
     
  2. fazox macrumors member

    Joined:
    Dec 16, 2007
    #2
    defaults write com.apple.Finder AppleShowAllFiles YES

    then

    killall Finder

    To hide the files again replace "YES" with "NO"
    then kill the finder again.
     
  3. BadlyDrawnGirl thread starter macrumors member

    Joined:
    Aug 25, 2006
    Location:
    New Zealand
    #3
    Sorry, this doesn't work either.

    Anyone have any ideas? :(
     
  4. GGJstudios macrumors Westmere

    GGJstudios

    Joined:
    May 16, 2008
    #4
    The proper command is:
    defaults write com.apple.finder AppleShowAllFiles TRUE
    then
    killall Finder

    Are you on an Administrator login? or Standard user?
     
  5. BadlyDrawnGirl thread starter macrumors member

    Joined:
    Aug 25, 2006
    Location:
    New Zealand
    #5
    I only have one login so I presume it is Admin. I have tried copying and pasting that exact command about a thousand times and it keeps coming up as not recognized.
     
  6. seashellz macrumors 6502

    Joined:
    Nov 18, 2004
    #6

    Be carefull in there

    If you are in admin, which is the first account you create at your first install, your prompt should look like this:
    ---

    Welcome to Darwin!
    Victoria:~mcd$ defaults write com.apple.Finder AppleShowAllFiles YES [restart finder]

    [invisible>visible -to make invisible again:]

    Victoria:~mcd$ defaults write com.apple.Finder AppleShowAllFiles NO [restart finder]

    to restart finder: hold down [cmd-opt-esc] all at once. a box will appear asking if youd like to relaunch finder?: Relaunch

    Edited
     
  7. BadlyDrawnGirl thread starter macrumors member

    Joined:
    Aug 25, 2006
    Location:
    New Zealand
    #7
    When I open Terminal, I do not get the "Welcome to Darwin!" message. This is what made me think something was wrong with my OS.
     
  8. Str8edgepunker macrumors 6502

    Joined:
    Nov 4, 2001
    Location:
    Philadelphia, PA
    #8
    TinkerTool has an option which allows you to view hidden files without mucking with default writes and that sort of thing. It also has a few other cool tweaks in it as well.
     
  9. BadlyDrawnGirl thread starter macrumors member

    Joined:
    Aug 25, 2006
    Location:
    New Zealand
    #9
    I suppose I can try that, but I was hoping to be able to do this without downloading too many apps (the real reason I'm trying to do this is so I can transfer my music from my iPod to my computer, which it looks like I'll have to download an app for ANYWAY if I can't figure out this Terminal issue). I was just wondering why a seemingly basic, simple command wasn't working and if this indicated a problem with my system.
     
  10. Watabou macrumors 68040

    Watabou

    Joined:
    Feb 10, 2008
    Location:
    United States
    #10
    Onyx is another one that lets you view hidden files in the finder.

    And when I open Terminal, I don't get Welcome to Darwin either. That's normal I think. Maybe you can provide a picture so we can see what you are typing and what command is not recognized?

    The command that works for me is

    Code:
    defaults write com.apple.finder AppleShowAllFiles TRUE
    and then type

    Code:
    killall Finder
    Then all types of files start to appear on my desktop and in the Finder: transparent images and .DS_Store files.
     

    Attached Files:

Share This Page