VineVNC with CotVNC

Discussion in 'Mac OS X Server, Xserve, and Networking' started by Rodney Chops, May 18, 2008.

  1. Rodney Chops macrumors newbie

    May 18, 2008
    I'm totally at my wits end with this one. I have:

    G3 Server, Running 10.3.9, and VineVNC server.
    - Firewall is Off
    - Remote Login is on
    - Apple Remote Desktop is OFF (because it says to in the instructions)

    A linksys router
    - Ports 5900-5910 forwarded to the server.

    A laptop, running leopard, and Chicken of the VNC.

    For the life of me I cannot get to connect. There even on the same network, no internet at all. I type in the IP and it just says Connection Refused. I've tried using DMZ, and pretty much everything I can think of.

    There must be something I'm missing, as this seems to be a common thing. It does not 'see' the server using bonjour or whatever it is supposed to do either.

    Any help would be much appreciated, I don't want to buy Apple Remote Desktop.

  2. stukdog macrumors 6502

    Oct 20, 2004
    Which version of COTVNC are you using? In our experience, 2.0b2 connects most often...though it would mean running via Rosetta.

    Another option is JollyFastVNC.
  3. Rodney Chops thread starter macrumors newbie

    May 18, 2008
    I tried the older version of Chicken and got the same 'cannot connect'. So then i tried jolly fast, it simply does nothing when I click connect so I'll assume its not working either. I also gave the demo version of vineviewer a shot, and it also would not work.

    Thanks for the suggestions though.

    Is there something you need to do when hosting a VNC server on panther? I used an external port scanner site to see if the port was open, and it is not. However, i'm not even connecting from an external IP. I'm just going from like, to This should be easy! :confused::confused::confused:
  4. GeeYouEye macrumors 68000


    Dec 9, 2001
    State of Denial
    If you don't mind having the Apple Remote Desktop port open, get rid of VineVNC and just turn on the ARD service; that'll start a VNC server on port 5900, as well as the actual ARD server. Just make sure you set a very good password, and you should be fine.

    Disclaimer: I'm only 98% sure this works on Panther. It doesn't on Jaguar and it does on Tiger.
  5. Rodney Chops thread starter macrumors newbie

    May 18, 2008
    Tried it, and it does not work with panther. I did eventually get it going by installing the ARD client, then using a reverse method with CotVNC. I have no idea why that helped or was any different. But its working now.


Share This Page