Virtual PC - Internet Connection

Discussion in 'Windows, Linux & Others on the Mac' started by Laisgb, Feb 27, 2007.

  1. Laisgb macrumors newbie

    Jan 19, 2007

    I have a PowerBook G4 version 10.4.8., which is connected to internet via "Built-in Ethernet", ADSL and working fine.

    I installed the Virtual PC for Mac version 7.0 and upgraded to 7.0.2.

    I'm having problems to have the VPC connected to internet. I've tried "Shared Networking" and "Virtual Switch". In both cases, when I try to open the Internet Explorer, it tells me that it cannot find the server. Anything I try to connect, like some "help" online, doesn't work at all.

    In Windows, the Local Area Connection Status shows that I am connected with some bytes being sent and some being received. I don't know much about it, but it seems that there is some kind of connection anyhow.

    I have been looking for help on internet, and trying everything. I'm not any expert, being just a "computer user". So, I'm struggling to understand what they say I have to do and following the advices. None of them worked out.

    Please, if someone knows what is going and help me, would be wonderful! I've been in this battle for weeks! Unfortunately I need the windows to run a software (for study and work), which is just for windows and time to time I need to be connected. I hope those information are enough to have some feed back.

    If there is no way, .... I'll have to buy a PC...., sadly...:(

    Thank you very much!
  2. 4JNA macrumors 68000


    Feb 8, 2006
    looking for trash files
    more info needed... vpc 7, but which version of windows? was the internet working before the upgrade to 7.0.2? how much memory in the laptop, and how much memory given to windows in vpc? easy way to find out is to open up vpc, click on Virtual PC, click on about Virtual PC, then click on the memory tab.

    should be using shared networking based on your internet connection. does your modem have a static ip? did you have to setup your laptop for networking, or just plug it into the modem, and you were on the internet? (dhcp or static)

    general idea based on your post is that your modem assigns your laptop an address, presto you are on the internet. fire up vpc and now the laptop is acting as a router/gateway for vpc when you choose shared networking, or 'NAT'. you might try opening a command window (start > run > command) and type 'ping' without the quotes to see if you have connection and naming issues. should come back with 'reply....' 4 times in a row if all is good.

    using vpc with several version of windows here, and can probably help if i get more info. best of luck.
  3. Laisgb thread starter macrumors newbie

    Jan 19, 2007
    Thank you! Here are the answers:

    - Windows version - XP Professional
    - Yes, the internet was the same before upgrading.
    - Memory:
    Built-in Memory - 512 MB
    Used by Virtual PC - 386 MB

    About that question:
    "...does your modem have a static ip? did you have to setup your laptop for networking, or just plug it into the modem, and you were on the internet? (dhcp or static)"

    ..I opened "Network Status" in Mac and I have the following info:

    "Built-in Ethernet is currently active and has IP address You are connected to the Internet via Built-in Ethernet".

    I don't know if with this information you're able to know about dhpc or static, and modem having static IP. If not, help me to find where I can get it, pls!

    Regarding setting the Mac, I just opened "sharing/internet" on "system preferences" and selected to share "built-in ethernet connection".

    About typing " ping ", it says..."Ping request could not find host Please check the name and try again".

    Well, hope you can figure out this, because I'm completely lost!

    If you ask me to do something, please tell me step by step, as all I know is to deal with some softwares, and the very basic about how a computer works. Promise I'll do my best!

    Thanks 4JNA!:)
  4. 4JNA macrumors 68000


    Feb 8, 2006
    looking for trash files
    good enough. lets start with the basic stuff. i will try and give step by step, and will use the format of 'apple' > 'about this mac' to indicate where to go and what to click next. if you doen't understand something, please let me know.

    you don't need to share the ibook internet connection as VPC will do that for you, so lets go back to 'system preference' > 'sharing' > 'internet', and turn off (uncheck) 'built in ethernet' and then click 'stop' to turn off internet sharing.

    next lets check the VPC settings. open VPC but don't start the pc (xp pro) yet. on the small 'Virtual PC list' box click the 'Settings...' button. if your setup doesn't keep the list window open (can't see the 'Virtual PC list' box), click on 'PC' at the top, and then click on 'PC settings...'. looking down the list in the middle, click on 'Networking' and on the right side you want a check mark in the 'enable networking' box, and a dot in the 'Shared Networking' option, then click 'OK'. this tells vpc to turn on the pretend ethernet adapter and the have the ibook give xp pro access to the network/internet.

    then start up the pc (xp pro). once it finally gets up and running, lets check some basic xp things. click on 'start' > 'control panel'. if you see 'Pick a category' in big letters on the right, then click on 'Switch to Classic View' on the top left. you should now see 30 something icons in the control panel. double click on 'System' to bring up the system property sheet. at the top, look to see if 'XP Professional, Version 2002, Service Pack 2' is listed. next click on the 'Hardware' tab > 'Device Manager' button > double click network adapters and see if the intel/generic adapter is listed. also looking to see if there are any question marks or exclamation points showing on the device manager list. if the adapter is listed, and there are no ?/! showing on the list, then you can close (X) the device manager window and 'OK' the system properties window.

    next, double click on the 'Networking' icon in the control panel and look at the 'Local Area Connection' on the right pane. should say 'Connected, Firewalled' if you are running SP2 or something close if not up to SP2 yet. if it says 'Disabled' the right click (CTRL + click) and select 'Enable'. next double click the 'Local Area Connection' icon to bring up the 'Status' window > click the 'Properties' button > double click on the 'Internet Protocol (TCP/IP)' in the list. you should have a dot next to 'Obtain an IP...' and 'Obtain DNS...', and then click 'OK > click 'OK' to close the properties sheet > and 'Close' on the connection status sheet.

    then go check to see if you can ping google, (start > run > command) and type the 'ping' again. if you get 'reply...', then you are on the internet, if not, then more xp fun...

    if not, then back to control panel (start > control panel), and double click on the 'Network Setup Wizard' icon. the wizard opens > Next > Next > dot next to "This computer connects to the Internet through a residential gateway...' and Next > (name/description if you want) Next > (workgroup name, anything, usually 'MSHOME' by default) Next > (file/printer sharing on or off, recommend off) Next > (settings summary) Next > choose 'Just finish...' and Next > Finish. now that i typed all that, don't remember if the wizard was there prior to SP2... if not, let me know. anyway, restart (start > shutdown > restart) the pc. when it comes back up, try to ping google again (start > run > command) and see if you get the 'reply...' that we are looking for.

    enough to start with... :eek: best of luck.
  5. Laisgb thread starter macrumors newbie

    Jan 19, 2007
    I'm sorry, 4JNA. I did everything you said step by step, by the way, very well explained, thank you!...., and the same message about "ping" showed up again..."Ping request could not find host Please check the name and try again".

    Now, about you said:
    When I clicked on Windows "System", it says "Version 2002 Service Pack 2", just like you wrote. Is that what you meant? If not, guide me to give you the right answer, pls!

    Now, I show you below some information:
    - "About VPC", if interest you. In the second attachment you'll see: "Networking Kext: Not Loaded". Is there something to do with?
    - In the last attachment says: "Local Area Connection 2"..., because I followed an instruction from internet weeks ago, and uninstall the device "Intel 21041-Based PCI...", and restarted windows. Doing that, it found by itself the device and named "...connection 2...". It supposed to work after that, but nothing changed. Do you think I should do it again as now I set for residential gateway?

    Well, well.., my "best of luck" still coming! Hope you are patient!


    Attached Files:

  6. Laisgb thread starter macrumors newbie

    Jan 19, 2007
    Hi 4JNA

    Today I found how to have the Windows Network Diagnostics, which is:

    1. Click Start
    2. Click Run
    3. Type netsh diag gui
    4. Click OK
    5. When the tool opens, click Scan Your System

    It came several information, which I'll show you the "FAILED" ones:
    - Intel 21041-Based PCI Ethernet Adapter (Generic)
    - DefaultIPGateway (request timed out)
    - DHCPServer (request timed out) - Packets: Sent = 4, Received = 0, Lost = 4 (100% loss)
    - DNSServerSearchOrder (request timed out) - Packets: Sent = 4, Received = 0, Lost = 4 (100% loss)

    And a "PASSED":
    - IPAddress - Packets: Sent = 4, Received = 4, Lost = 0 (0% loss)

    ..and hundreds more information that I don't have idea what they are.

    Pls, tell me that it helps!

  7. Rick450 macrumors newbie

    Jan 25, 2008
    Same exact problem...

    Hello guys, I have nearly the exact situation happening with me, same computer and all. Where did you guys leave off with this problem? Any new solutions?


Share This Page