Virtualbox doesn't work

Discussion in 'Mac OS X Lion (10.7)' started by siwsan, Jul 5, 2011.

  1. siwsan macrumors newbie

    Joined:
    Jul 5, 2011
    #1
    I'm very upset over Lion and think it's the worst OS X release since 10.0 which was a disaster. I find Lion extremely sluggish and somewhat buggy, and as I see it, it's definitely not ready for primetime.

    One of the things that makes me mad is that Virtualbox doesn't work anymore. I have a bunch of virtual machines I need to run (OpenBSD, NetBSD, Windows XP and 7) and in Lion, Virtualbox (4.0.10) crashes when one tries to start a virtual machine no matter what guest OS (they don't even survives past BIOS boot). It worked flawlessly in SL.

    Is there anything I can do except revert to Snow Leopard?
    I have already tried to disable VT-X, 3D, PAE/NX and IO APIC in Virtualbox, but no go. :mad:
     
  2. fm2503 macrumors member

    fm2503

    Joined:
    May 5, 2009
    Location:
    North Wales
    #2
    I think you need to be booted in K64 for VirtualBox to work on Lion. Since 4.0.10 I haven't had any issues with VBox on Lion GM.
     
  3. hopejr macrumors 6502

    Joined:
    Nov 10, 2005
    Location:
    New South Wales, Australia
    #3
    :confused: It hasn't even been released to the public yet and you're complaining like this??? Besides, a .0 release is never close to perfect.
     
  4. sudoash, Jul 5, 2011
    Last edited: Jul 5, 2011

    sudoash macrumors member

    Joined:
    Jun 12, 2011
    #4
    VirtualBox 4.0.10 works fine with my existing VM, had no problems at all. It might be something to do with the configuration of each VM. Can you post your System Settings for one of your VMs?

    Edit: Also, you didn't actually post what the error was -- could you please do so. Usually you can fix any problems with the virtual machines. It might be a corrupt XML in your <vm_name>.vbox file.
     
  5. hellfried macrumors member

    Joined:
    May 3, 2008
    #5
    How does one boot into K64?
     
  6. ajcrow93 macrumors member

    Joined:
    Jun 14, 2011
    #6
    I think that you hold down the 6 and 4 keys after rebooting. :D
     
  7. fm2503 macrumors member

    fm2503

    Joined:
    May 5, 2009
    Location:
    North Wales
    #7
    From an elevated terminal session you can do:
    systemsetup -getkernelbootarchitecturesetting
    to report what it currently is and
    systemsetup -setkernelbootarchitecture i386 to set it to K32 or
    systemsetup -setkernelbootarchitecture x86_64 to set it to K64

    and then reboot.

    This will be apply to every subsequent reboot. The already pointed out alternative of holding down 64 (or 32) to boot that kernel will still over ride this.
     
  8. EmmEff macrumors regular

    Joined:
    Oct 27, 2010
    Location:
    Ontario, Canada
    #8
    If you need to run these VMs, why did you immediately jump on the latest OS X upgrade without having at least tested the environment first? Obviously you didn't *need* them...
     
  9. siwsan thread starter macrumors newbie

    Joined:
    Jul 5, 2011
    #9
    I assumed it would work. However, I have reverted to my previous
    SL-install. SuperDuper is an excellent tool for disk cloning! :)

    VirtualBox was giving me the error:
    "Callee RC: NS_ERROR_ABORT (0x80004004)"

    By the way: I thought Lion's default boot was in 64-bit mode.
    Otherwise, what is the reason that Apple says that Core Duo and
    Core Solo isn't supported due to lack of 64-bit capability?
    Anyways, VirtualBox still didn't work after booting K64.

    Perhaps I will migrate to Lion when 10.7.7 comes out. :D
     

Share This Page