VirtualBox Networking problem

Discussion in 'Mac Apps and Mac App Store' started by FortWorthMac, Jun 16, 2009.

  1. FortWorthMac macrumors 6502a

    Joined:
    Oct 29, 2008
    Location:
    the parched earth of North Texas
    #1
    Hello all,

    Here is my setup:

    iMac with a wired connection
    PC Laptop with Vista
    VirtualBox running Windows 7 (RC)

    All three devices are on the same workgroup.
    The iMac can see shares on the laptop and the laptop can see shares on the iMac.
    The VirtualBox can ping both other devices.

    My problem is, on my VirtualBox I cannot see other network shares. Either on my laptop or my PC. That's strange since I can ping each of them.

    I've tried it with both the firewalls on and off.

    Any clues?

    Thanks
    David
     
  2. uberamd macrumors 68030

    uberamd

    Joined:
    May 26, 2009
    Location:
    Minnesota
    #2
    I believe this is because VirtualBox uses NAT by default, meaning its on its own network and data is sent through the host's network interface. If you use bridged networking, you should get a IP that works.
     
  3. FortWorthMac thread starter macrumors 6502a

    Joined:
    Oct 29, 2008
    Location:
    the parched earth of North Texas
    #3
    Thanks for the reply.

    I'm fairly computer/networking literate but I gotta admit you lost me there. <G>

    David
     
  4. uberamd macrumors 68030

    uberamd

    Joined:
    May 26, 2009
    Location:
    Minnesota
    #4
    In your VirtualBox window, click Network, change "Attached to" from NAT to Bridged Adapter, press OK, then start the virtual machine up again. Should work.
     
  5. FortWorthMac thread starter macrumors 6502a

    Joined:
    Oct 29, 2008
    Location:
    the parched earth of North Texas
    #5
    Looks like that did it.

    Thank you sir!

    David
     
  6. uberamd macrumors 68030

    uberamd

    Joined:
    May 26, 2009
    Location:
    Minnesota
    #6
    No problem, enjoy!
     

Share This Page