Vista Doesn't Recognize Blu-Ray Disk

Discussion in 'Windows, Linux & Others on the Mac' started by fridgeymonster3, May 12, 2009.

  1. fridgeymonster3 macrumors 6502

    fridgeymonster3

    Joined:
    Jan 28, 2008
    Location:
    Philadelphia
    #1
    So, I recently installed an LG GGC-H20L Blu-Ray and HD DVD drive into the second bay of my mac pro. This in itself was an absolute pain, as I had to enable AHCI for Windows Vista by using a modified mbr because I was using one of the ODD_SATA ports on the motherboard which Windows doesnt' "see" cause it runs in legacy mode. Everything there went completely fine, as now I am running in AHCI mode and I can see the LG drive and I can play CD's and regular DVD's via that drive in Windows Vista. However, the problem now is that when I insert a Blu-Ray or an HD DVD, Windows doesn't even recognize that there is media in the drive. It says there is no disc inside. When I boot in OS X, I can clearly see both the HD DVD and Blu_ray (although I can't play it or do anything with it). So, can someone help me out trying to get Windows Vista to recognize the damn discs so I can play them! Please help!
     
  2. fridgeymonster3 thread starter macrumors 6502

    fridgeymonster3

    Joined:
    Jan 28, 2008
    Location:
    Philadelphia
    #2
    I know this is essentially a *bump*, but does anybody have any suggestions to remedy my situation? I've done all the hard work and now I'm freaking stumped by an easy problem. I know I'm just missing something obvious....help me with my brain freeze :)
     
  3. albusseverus macrumors 6502a

    albusseverus

    Joined:
    Nov 28, 2007
    #3
    Wish I could help, but I can't.

    I know Caveman does a lot of BD on his Mac, you could try to PM him and see if he's got any suggestions.

    Have you, at least temporarily, tried putting the LG in one of the more 'visible' SATA ports to see if that helps?

    But try Caveman first. See if he's got any suggestions.
     

Share This Page