Vista has become default boot......?

Discussion in 'Windows, Linux & Others on the Mac' started by NJFP, Feb 18, 2009.

  1. NJFP macrumors 6502

    Joined:
    Feb 18, 2009
    #1
    Hello all. I am new to Mac, but very old to computing. I just installed Vista on my MacBook Pro. It works well, but now the stupid Vista is the default boot! How do I switch it back to Mac default boot? Also, how can I rename and remove the Vista drive icon from my desktop?

    Someone please help the nub!!!!
     
  2. Trip.Tucker Guest

    Joined:
    Mar 13, 2008
    #2
    1. System Preferences
    2. Startup Disk
    3. Click on Leopard as preferred boot partition.
    4. Click on Restart to register the change.
     
  3. richard.mac macrumors 603

    richard.mac

    Joined:
    Feb 2, 2007
    Location:
    51.50024, -0.12662
    #3
    hold option on startup and select Macintosh HD if you dont know how to boot back into OS X. Control Panel in Windows also has the Startup Disk options.

    to hide the Windows partition from OS X rename it in Windows and put a period before the name. anything that has a filename which starts with a period in OS X is hidden.
     
  4. Trip.Tucker Guest

    Joined:
    Mar 13, 2008
    #4
    To hide your Vista (*puke*) volume on OS X, drop into a shell, Terminal and run this:

    SetFile -a V /Volumes/Pista

    Then restart the finder to have the change take effect:

    killall Finder

    You will need to have installed the developer tools from your OS X install disk.
     
  5. NJFP thread starter macrumors 6502

    Joined:
    Feb 18, 2009
    #5
    I knew someone could help! Thanks all, for the tips!! That worked nicely.
     

Share This Page