Vista installation cd ejects when I try to install in boot camp!

Discussion in 'Windows, Linux & Others on the Mac' started by luffytubby, Jul 10, 2008.

  1. luffytubby macrumors 6502a

    luffytubby

    Joined:
    Jan 22, 2008
    #1
    Havent used boot camp in a while, but last time I used it(before the update) it worked fine!


    boot camp has no problem making a partition, but when it reboots to install, it reboots and upon starting up, the vista CD ejects..


    I tried partitioning and deleting my partitions several times, and I uninstalled WMWare fusion to make sure it was not that, that was messing with things...


    Anyone know what to do? I was told to hold C key down upon start up, but it didnt help.

    I can see the contents of the vista disc in osx just fine, so i dont think its scratched or anything(its a new vista CD)... I just dont get why it dont work all of a sutten!


    its home premium 64 bit!
     
  2. luffytubby thread starter macrumors 6502a

    luffytubby

    Joined:
    Jan 22, 2008
    #2
    I tried some more.

    It seems that the parition is fine. I put in the vista installation CD. Open boot camp assistent. machine reboots.

    I hold down ALT key upon start up.

    screen becomes grey and shows that I can choose between Macintosh HD and the Vista CD.


    I choose boot from vista CD

    screen goes completely grey with black apple logo in middle. seems to just hang there for 5-10 minutes. I assume its frozen!? Tried it it three times now!
    Should I perhaps just let it stand like that all night?
     
  3. iShater macrumors 604

    iShater

    Joined:
    Aug 13, 2002
    Location:
    Chicagoland
    #3
    I thought Vista wasn't supported, and only XP SP2 was. :confused:
     
  4. luffytubby thread starter macrumors 6502a

    luffytubby

    Joined:
    Jan 22, 2008
    #4
    nope.


    When I got the Imac a while ago I got boot camp up and running with no problems with vista 64 bit.

    When I later tried WMWare Fusion, I deleted my Boot Camp partition, and used the same windows vista 64 bit on wmware fusion and activated it! then I didnt like it so much so I want boot camp back...

    but now boot camp wont run at all. its like WMWare fusion/or OSX ruined the Vista install CD.
     
  5. luffytubby thread starter macrumors 6502a

    luffytubby

    Joined:
    Jan 22, 2008
    #5
    So I have been sitting all night, trying to figure out what was wrong!



    I tried doing the check up in user single mode(Command + S) doing start up, by entering /sbin/fsck - fy

    But it was hard to type because after a short while, each line I tried to write would get interfered by another command saying " : root# AppleUSBEHCI[0x6e8t000] :: Found a transaction past the completion deadline on bus oxfd, timing out!(Addr: 6, EP:4)"


    I don't know its supposed to say that during the console prompt, but I finally got to type it, and it said that the Macintosh HD was ok! I pressed exit, and it went through a long phase where it first seemed to check(displaying code... and obscure names and checkups) and then it went to a light blue screen for 5 minutes before it returned to the desktop!



    I also found out that it was not my superdrive that was dead! I tried putting in an DVD, and my Imac has no problem playing back does files.
    But when I put in the Leopard install CD because I wanted to install Leopard again, and it rebooted... it did exactly the same thing like my windows vista DVD! It ejected when starting up! Damn!
    So it's probably not the DVD drive.




    Then I tried Refit, which is a boot program( http://refit.sourceforge.net/ ) I got it working after much hassle but it wouldnt let me install Vista. In fact it didnt even displayed my newly partitioned boot camp partition. It just showed my macintosh HD, my EFI partition(or whatever that was) and my external my book hard drive...

    So I am beginning to think that it might be the boot camp partition that is messed up, and thats why mac windows wont install...

    But Boot camp assistent does give me any options to anything. If I recall right, you could choose a bunch of thing in boot camp assistent. It says when examing it, that its a fat32 partition(which I am glad) but I dont know why its not working... I cant format it within the disk utility, or do anything to it.
    I tried the "picture" option, and it made a .dmg clone of my boot camp partition... I dont know whats that for, and no - I couldnt install vista on that either.





    Then I tried retting my PRAM and NVRAM with the Alt + Command + P + R option doing start op, but it had no effect either(It did make an extra sound doing boot up, but its supposed to do that, right!?)



    So now I dont know what to do. I feel I am out of options here. anyone got any suggestions?
     
  6. luffytubby thread starter macrumors 6502a

    luffytubby

    Joined:
    Jan 22, 2008
    #6
    When I go into system preferences > startup disk, I cant see any boot camp partition.

    it can only start form Macintosh HD or some network server, which I dont know what is:I

    Anyone know if its supposed to be like that?



    in disk utillity I ran a "looking for problem" test with my Macintosh Hard Drive, and it said that it was fine, but when it checked the boot camp partition the following came up:

    controlling unit “BOOTCAMP”
    ** /dev/disk0s3
    ** Phase 1 - Preparing FAT
    ** Phase 2 - Checking Directories
    ** Phase 3 - Checking for Orphan Clusters
    45 files, 211044288 KiB free (6595134 clusters)


    anyone know what that means?



    in bottom left corner when viewing the Boot Camp partition, it says: Owner: Disabled


    the boot camp is active and I can see it on my desktop. hmmmm.
     
  7. luffytubby thread starter macrumors 6502a

    luffytubby

    Joined:
    Jan 22, 2008
    #7
    Have now tried doing the apple hardware test - no problems found.


    however during start up and pressing C for forced start from CD/DVD it ejected the leopard CD!


    I wanted to start from the CD so I could see if the boot camp partition had been journaled or not. I heard you can check it in there. hmmm... this is really strange.
     
  8. luffytubby thread starter macrumors 6502a

    luffytubby

    Joined:
    Jan 22, 2008
    #8
    okay, it may be the super drive after all... other people who have the same problem(after searching a bit) seems to say that its due to an ineffective super drive... apparently they suck:(


    damn... just got this machine... dont wanna take it back now*sigh*...
     
  9. luffytubby thread starter macrumors 6502a

    luffytubby

    Joined:
    Jan 22, 2008
    #9
    after some more tweaking and testing I found out that i could start from windows(boot camp) when i pressed Alt(option) doing start up but i got this messege; "non-system disk press any key to reboot"!

    except.. i couldnt press anything keys where dead:I





    tried running a program called partition inspector, it gave me this analyzis of my hard drives:



    *** Report for internal hard disk ***

    Current GPT partition table:
    # Start LBA End LBA Type
    1 40 409639 EFI System (FAT)
    2 409640 1531068455 Mac OS X HFS+
    3 1531330600 1953525127 Basic Data

    Current MBR partition table:
    # A Start LBA End LBA Type
    1 1 409639 ee EFI Protective
    2 409640 1531068455 af Mac OS X HFS+
    3 * 1531330600 1953525127 0c FAT32 (LBA)

    MBR contents:
    Boot Code: Unknown, but bootable

    Partition at LBA 40:
    Boot Code: None (Non-system disk message)
    File System: FAT32
    Listed in GPT as partition 1, type EFI System (FAT)

    Partition at LBA 409640:
    Boot Code: None
    File System: HFS Extended (HFS+)
    Listed in GPT as partition 2, type Mac OS X HFS+
    Listed in MBR as partition 2, type af Mac OS X HFS+

    Partition at LBA 1531330600:
    Boot Code: None (Non-system disk message)
    File System: FAT32
    Listed in GPT as partition 3, type Basic Data
    Listed in MBR as partition 3, type 0c FAT32 (LBA), active



    I think the last one is my boot camp partition... "non-system disk messege"!


    what does that mean?
     
  10. luffytubby thread starter macrumors 6502a

    luffytubby

    Joined:
    Jan 22, 2008
    #10
    This is what It came back with when I ran diskutil:

    diskutil list
    /dev/disk0
    #: TYPE NAME SIZE IDENTIFIER
    0: GUID_partition_scheme *931.5 Gi disk0
    1: EFI 200.0 Mi disk0s1
    2: Apple_HFS Macintosh HD 729.9 Gi disk0s2
    3: Microsoft Basic Data BOOTCAMP 201.3 Gi disk0s3
    /dev/disk1
    #: TYPE NAME SIZE IDENTIFIER
    0: FDisk_partition_scheme *931.5 Gi disk1
    1: Windows_FAT_32 My Book 931.3 Gi disk1s1
    /dev/disk2
    #: TYPE NAME SIZE IDENTIFIER
    0: FRMCxFRE_DA_DVD *3.5 Gi disk2



    edit... and when I searched on the boot camp disc specificaly:


    Device Identifier: disk0s3
    Device Node: /dev/disk0s3
    Part Of Whole: disk0
    Device / Media Name: Untitled

    Volume Name: BOOTCAMP
    Mount Point: /Volumes/BOOTCAMP
    File System: MS-DOS FAT32

    Partition Type: Microsoft Basic Data
    Bootable: Is bootable
    Media Type: Generic
    Protocol: SATA
    SMART Status: Verified

    Total Size: 201.3 Gi (216110792704 B) (422091392 512-byte blocks)
    Free Space: 201.3 Gi (216109285376 B) (422088448 512-byte blocks)

    Read Only: No
    Ejectable: No
    Whole: No
    Internal: Yes



    so its bootable!!! is that a good or a bad thing?
     

Share This Page