Vista / Mac sharing mystery

Discussion in 'macOS' started by Olvenskol, Feb 5, 2009.

  1. Olvenskol macrumors member

    Joined:
    Feb 20, 2008
    #1
    Oh good, another thread about file sharing / printing between Vista and Mac ...

    Anyhow, here is my mystery. I have an Macbook Air with current version of Leopard and a pretty new HP desktop with up-to-date Vista Home Premium running. Networking is being handled by an Airport and generally it all works fine.

    In the past, I setup a shared printer on the Vista machine and it worked fine. I also have occasionally transfered files between the machines, though I was never able to get Finder's Sharing section to see the Vista machine. I would remote mount a Samba disk to do the sharing and that worked fine.

    I haven't used either facility in some months. Today, I tried both and ran into problems with both. The printing error is NT_STATUS_CONNECTION_REFUSED. An attempt to connect a shared drive in Finder results in a message about the machine name not being found.

    I tried many things, including reinstalling the printer (it worked fine, then stopped) and enabling NTLMv2 authentication in smb.conf. Everything seemed mysterious until I figured out the pattern. And the pattern is this...

    If I reboot my Mac, I can mount a drive one time and print one document. After that, neither printing nor remounting the same drive works. If I reboot, then the queued document prints and I'm then back to not being able to print.

    Anyone encounter this works-once behavior before? I'm quite mystified by it!

    Edit: of course, immediately after hitting "Submit", I got a new behavior. The printer woke-up and printed one of the queued documents, this after sitting dead for about 10 minutes, but I didn't reboot. The second document in the queue once again is getting the "connection refused" error.
     
  2. darkcurse macrumors 6502a

    darkcurse

    Joined:
    Nov 5, 2005
    Location:
    Sydney
    #2
    Just a quick question, are both your computer's on the same domain? Maybe setting your Mac to the same domain as the PC would alleviate the problems?
     
  3. Olvenskol thread starter macrumors member

    Joined:
    Feb 20, 2008
    #3
    Good question! I forgot to mention that that was the first thing I tried.
     

Share This Page