Vista not connecting to router on MBA

Discussion in 'Windows, Linux & Others on the Mac' started by noizz, Jan 30, 2009.

  1. noizz macrumors newbie

    Joined:
    Jan 30, 2009
    #1
    So as the title states, I'm having trouble getting the wireless to work through Vista on my MBA.

    The router is a dlink DIR-615, supports wireless-N. It works fine when I'm in OS X. But when I'm in Vista, it shows up, but when I try to connect it won't work. Basically it just says it cannot connect to the router, and it tells me to select a different network.

    Router settings on the DIR-615:
    - mixed mode a/b/g/n
    - channel 6
    - WPA/WPA2 encryption
    - AES cipher

    I tried manually setting up the connection with the corresponding settings on the router through the settings, but no luck. I tried connecting to a different router, WRT-54G the popular linksys one, no problems with that.

    Boot Camp drivers have been installed. Its weird, I had this problem setting up my PS3 (playstation 3) before; It would connect, but it was unable to access internet. I had to disable/enable the PS3 wireless system to get it working again.

    My sister has a macbook pro 12", and she hasn't had any problems connecting through OS X.

    I'm a first time Mac user, am I missing anything?
     
  2. cuestakid macrumors 68000

    Joined:
    Jun 14, 2006
    Location:
    San Fran

Share This Page