Vista problems finding Mac ethernet card... driver needed?

Discussion in 'Windows, Linux & Others on the Mac' started by GregUofMN, Feb 1, 2008.

  1. GregUofMN macrumors regular

    Joined:
    Nov 15, 2003
    #1
    Hi All--

    I first attempted to use Windows Vista Home Premium through Parallels 3.0, but gave up due to the unreliability of Parallels. (It would start 90% of the time when I opened the program from home and never opened at my office. I would shut off the wireless detector and it never changed the outcome.) As a result, I am currently using Vista natively through Bootcamp--which makes my CAD programs run much more smoothly and faster anyway.

    But here's the major problem. I, along with the company PC/IT tech support, are having trouble connecting Vista to the ethernet and company server because the same error message keeps popping up. It keeps asking for an ethernet driver to be installed because it is not reading the ethernet hardware on the mac side of the machine. Has anybody else had this problem?

    Also, the PC/IT tech support guy said that all versions of Vista (home basic, home premium, business, ultimate, etc) can be connected to network servers and utilize remove server access. Of course, after purchasing the Home Premium version, opening the packaging and installing the software did I notice on the back of the packaging that it doesn't work with business servers and remote access. I confronted our IT tech and he said that it didn't matter and that he knew some alternative way to gain access. I'm not a PC guy so I have no idea. Is he right? Or did I just spend $250 on an OS that won't do what I need it to do?

    Thanks,
    Greg
     
  2. parapup macrumors 65816

    parapup

    Joined:
    Oct 31, 2006
    #2
    What Apple computer do you have - is it a MacBook/MacBook Pro/Mac Mini/Mac Pro?

    In any case I think Apple uses the same hardware for the ethernet and Vista works after installing the built in driver.

    Do this -
    1) Click on Start, Type Device Manager in the search box
    2) Device Manager will show up - click it, it will ask permission, click continue
    3) A Window will open up - with a list of devices. Click and expand the Network Adapters tab if it is not already
    4) Right click on "Ethernet controller" and Click Properties
    5) Click on "Driver" tab
    6) Click Update Driver
    7) Click "Browse my computer for driver software"
    8) Click "Let Me Pick from a list ....."
    9) In the left hand side Manufacturer list Find "Marvell" and click it
    10) Select the first entry "Generic Marvell Yukon ..."
    11) Click next - it will warn, say yes. It is ok.

    Connect to the internet and run Windows update - it will download and install the more correct driver automatically along with other things.

    Hope this helps!
     
  3. GregUofMN thread starter macrumors regular

    Joined:
    Nov 15, 2003
    #3
    I have a MacBook Pro. Wow thanks for the response! I really appreciate it! But here's a stupid question. Do I do this in Leopard or Vista? Also, if I do this in Vista, how can I download the ethernet driver if I cannot even connect to the internet?

    Thanks again,
    Greg
     
  4. parapup macrumors 65816

    parapup

    Joined:
    Oct 31, 2006
    #4
    You do these steps in Vista. Vista ships with lots of drivers that are built-in - that is they live on your hard drive. In your case there is a close match driver available on your hard drive and you just need to tell Vista to use the closest match until you can connect to the internet and download the exact driver.
     
  5. GregUofMN thread starter macrumors regular

    Joined:
    Nov 15, 2003
    #5
    I'm able to do everything thru steps #10. I found the "Generic Marvell Yukon Chipset based Ethernet Controller #2" and installed the driver software. However, it gives me this message...

    Windows encountered a problem installing the driver software for your device. Windows found driver software for your device but encountered an error while attempting to install it.

    Generic Marvell Yukon Chipset Based Ethernet Controller

    This operation returned because the timeout periord expired. If you know the manufacturer of this device, you can visit its website and check the support section for driver software.


    I went online on a different machine and found these two websites...

    Generic Marvell Driver
    http://members.driverguide.com/driver/detail.php?driverid=892358

    Generic Marvell Yukon Chipset based Ethernet Controller Driver
    http://members.driverguide.com/driver/detail.php?driverid=607486

    They cost $2.99 for the driver so I don't want to just pay and download something that won't work. Do you have any other ideas?

    Thanks again for all your help. I really appreciate it!
     
  6. parapup macrumors 65816

    parapup

    Joined:
    Oct 31, 2006
    #6
    I would suggest never to download and install things like Drivers from sites that you cannot trust for security reasons.

    That being said - the error that you got sounds like you selected "Network Controller" instead of "Ethernet Adapter" in step #4, yes? If so repeat the steps and select "Ethernet Adapter" this time.

    If that doesn't work and you have a USB drive somewhere, go to the Network Card vendor Marvell's site and download it. Copy it and install it by running the setup.exe - rest should be easy.

    I am assuming you are using Vista 32-bit (Start->Computer->System Properties->System Type) - if not, let me know. The driver download URL is different.
     
  7. GregUofMN thread starter macrumors regular

    Joined:
    Nov 15, 2003
    #7
    Thanks! I'll give it a shot tonight and I'll let you know how it works out.

    Thanks again for all the help. Is this a Vista-on-Mac-only issue or do PC/Vista users have these types of difficulties too?
     
  8. Consultant macrumors G5

    Consultant

    Joined:
    Jun 27, 2007
    #8
    When you are booted in windows, have you put in your leopard disk to install bootcamp drivers?
     
  9. GregUofMN thread starter macrumors regular

    Joined:
    Nov 15, 2003
    #9
    No, but wouldn't it be a Window's driver I'm looking for not a bootcamp driver?
     
  10. GregUofMN thread starter macrumors regular

    Joined:
    Nov 15, 2003
    #10
    I don't have Ethernet Adapter as an option. This is the list under Device Manager:

    Batteries
    Computer
    Disk Drives
    DVD/CD-ROM drives
    Human Interface Devices
    IDE ATA/ATAPI controllers
    IEEE 1394 Bus Host controllers
    Imaging devices
    Keyboards
    Mice and other pointing devices
    Network adapters (This is where the Generic Marvell Yukon is.)
    Other devices
    Processors
    Sound, video and game controllers
    Storage controllers
    System devices
    Universal Serial Bus controllers

    Any other ideas?
     
  11. webgoat macrumors 6502a

    webgoat

    Joined:
    Sep 20, 2007
    Location:
    Austin, TX
    #11
    you need to install the boot camp drivers from your leopard install dvd in windows and your prob will be fixed
     
  12. parapup macrumors 65816

    parapup

    Joined:
    Oct 31, 2006
    #12
    Ah so you do have a Leopard DVD? If you'd said that it would've saved you some trouble! :)

    Any way if you do and if you use 32-bit Vista your problem is solved - just boot to Vista and pop-in the DVD and run the Boot Camp setup from the DVD.
     

Share This Page