Vista RC1 Help

Steve Jobless

macrumors 6502
Original poster
May 31, 2006
304
0
I've heard some people have managed to get the drivers CD working for them in vista but I cant get all of the drivers to install. (what doesnt work: right click with out mouse, isight, full sound, bluetooth)

I really would like for bluetooth and right click to work, the others arent as important.

Also I can't shutdown in vista, when I hit shutdown it goes to sleep, then I have to wake it, click on switch users then shutdown.

if it matters I use a macbook pro with a 12 GB partition.
 

emptyCup

macrumors 65816
Jan 5, 2005
1,483
1
So the pre-release version of Vista doesn't work perfectly in the beta version of Bootcamp. Hmm. Apple just got iSight working under XP. As far as I know the news is that Vista works under Bootcamp (as it was not previously thought that it would). Are you sure that you heard that everything was working?
 

bearbo

macrumors 68000
Jul 20, 2006
1,863
0
aside from there are like 50 threads on vista in bootcamp(, and yes, all version of vista were tested)...

if you are using RC1, you can expect the following item not working
isight
brightness
eject

eject worked in the pre-RC1, but not longer works by the same method (well, i can't get it to work, some people can probably... and if you can, tell me please)

bluetooth i can't try, but it installed just fine, altho i can't complete the disk installation due to a "fatal error"

but again... search and check existing threads before start another one
 

Virtualball

macrumors 6502
Jun 5, 2006
399
8
hehe Im the one who had the thread about the methods posted above. Im downloading Vista post-RC1 and Ill see what I can do with driver support. Especially cuz now we have 1.1.1 :p
 

HennyDaLoc

macrumors newbie
Sep 22, 2006
5
0
ACPI BSOD during boot to Vista RC1 Install Disc

I have seen where several other MacBook Pro owners where able to install Vista with minimal problems. Helping me just boot to the disc would be tremendious.

Everytime I boot to the Vista RC1 Install disc, I receive the ACPI Blue Screen referencing non-compliant BIOS. I know the MacBook Pro doesn't use BIOS and runs of off EFI, however, I have seen in several forums where deleting the EFI partition was not necessary in order to complete the Vista install.

Any suggestions so that I can at least boot to the disc would be most helpful.

BTW...I am not able to boot to the Vista Disc using Parallels either...same ACPI BSOD. Burn a new disc maybe? Has any one else had this problem???:mad:
 

Virtualball

macrumors 6502
Jun 5, 2006
399
8
To boot from a disc, reboot and hold the c key. Yes, re burn another CD and do it at the slowest speed possible. That way it wont mess up (it usually doesnt but what ever :p)
 

Steve Jobless

macrumors 6502
Original poster
May 31, 2006
304
0
im honestly going crazy here, the cd didnt include a bluetooth driver and i refuse to waste another cd on the stupid drivers i've used two already. right click is no longer an issue due to the fact that I have a mighty mouse that was picked up rather quickly. I managed to install the Isight, although I rarely use it. I also managed to get the eject button to work too.

my two issues are bluetooth and the lack of shutdown.

if someone could upload th bluetooth driver id appreciate it alot.
 

bearbo

macrumors 68000
Jul 20, 2006
1,863
0
Steve Jobless said:
im honestly going crazy here, the cd didnt include a bluetooth driver and i refuse to waste another cd on the stupid drivers i've used two already. right click is no longer an issue due to the fact that I have a mighty mouse that was picked up rather quickly. I managed to install the Isight, although I rarely use it. I also managed to get the eject button to work too.

my two issues are bluetooth and the lack of shutdown.

if someone could upload th bluetooth driver id appreciate it alot.
first of all, what built of vista?

how did u get isight to work? and how did you confirm it really worked?
did you get brightness/eject to work?

anyone tried play games under vista, namely SWAT 4 and GRAW, do they work as good as in XP? (for this, i need fact, as in if you did it personally, i dont need speculation like 'it should work')
 

Virtualball

macrumors 6502
Jun 5, 2006
399
8
Well I got the newest version of Vista on my MacBook. Im happy to say that with 1.1.1, the eject key works! Woo! haha
 

Steve Jobless

macrumors 6502
Original poster
May 31, 2006
304
0
i guess i should add ever since i added the isight driver and the other apple drivers ever time i log into vista after a restart i get the bsod.

its verry annoying plus this thing has the worst memory managment every i started with a 12.2 GB partition and now im down to only 2.05 GB free.
 

bearbo

macrumors 68000
Jul 20, 2006
1,863
0
Steve Jobless said:
build: 5600
bootcamp: 1.1.1
iSight: this threads instructions http://forums.macrumors.com/showthread.php?t=228741
my mbp recognized it right after i did that, but i didnt test it
i didnt bother with brightness but the eject did work, you have to download the system32 file on the second page of this thread http://forums.macrumors.com/showthread.php?t=228741
isight i can get it to install and LOOK it works, but testing it shows it's not...

and please i dont need you to tell me what you think works if you didn't try... and did you happen to notice that I uploaded the system32 file? and no, as i said, using the same method didn't produce the same result for me. dont know why... so you did get it to work with 5600 using the system32 file i uploaded?

Steve Jobless said:
i guess i should add ever since i added the isight driver and the other apple drivers ever time i log into vista after a restart i get the bsod.

its verry annoying plus this thing has the worst memory managment every i started with a 12.2 GB partition and now im down to only 2.05 GB free.
how is that a bad memory management if it takes up your harddrive...
btw, does anyone know what is supposed to be vista's size? it seems like (as Steve said) it's constantly eating up space, slowly but surely...
 

Steve Jobless

macrumors 6502
Original poster
May 31, 2006
304
0
bearbo said:
so you did get it to work with 5600 using the system32 file i uploaded?


how is that a bad memory management if it takes up your harddrive...
btw, does anyone know what is supposed to be vista's size? it seems like (as Steve said) it's constantly eating up space, slowly but surely...
Yes 5600 did work with the file YOU uploaded, if you're having issues I don't have any ideas on how to help except that holding the eject button for 5 or more seconds does the trick.

also I did mean hard drive space, just mixed up what I meant, anyways I do belive the install file is around 5 GB (not sure if this is true but I read somewhere that it includes the other versions of Vista somewhere). Im sure the HD space missing is due to system restore and several updates.
 

suneohair

macrumors 68020
Aug 27, 2006
2,137
0
I tried to install on my Mac Pro and I get the "non compliant bios" when it goes to restart the first time. Any ideas?
 

bearbo

macrumors 68000
Jul 20, 2006
1,863
0
aside from isight and eject and brightness (well, i deleted vista, it's just not worth it at this point yet)... some games just can't work out right
e.g. 1. SWAT4, the bottom 1/8 of the screen is not correctly displayed (at 800x600, problem increase using higher res.)
2. GRAW, apparently due to the way the saved files are stored, the game/OS hangs between missions

so i'm back to XP, maybe i'll try it again few months later...