Vista x64 on October 15th Macbook Pro Release

Discussion in 'Windows, Linux & Others on the Mac' started by kkrull, Oct 15, 2008.

  1. kkrull macrumors regular

    kkrull

    Joined:
    Dec 19, 2006
    #1
    I am stuck in several ways getting Vista x64 triple booting with rEFIt on the October 15th released Macbook Pro.

    First, I fixed my Vista x64 SP1 disc to be usable by an EFI Macbook.

    Second, I forgot to create the boot camp drivers (turns out they are on the Leopard install disk so this is a non-issue).

    Third, I created the partitions as outlined in various triple boot writeups, only my version of OSX wouldn't create a "linux" partition and there were no ext like options, so I created two FAT32 partitions one called Linux (to be reformatted as ext3 later) and one called Windows (to be formatted as NTFS).

    Fourth, I installed rEFIt 0.11.

    Fifth, I rebooted. I get a text based version of rEFIt which doesn't see the CD. There is some text that flashes on the screen quickly and then I see text based menus. No option to load from CD.

    Sixth, I hold the 'C' key and reboot to force the machine to load the CD. It does. I load the Vista installer. Yes, I do have to reformat the Windows partition to NTFS but it finishes. Left mouse click works fine by the way.

    Seventh, I try to load Windows from rEFIt text menus but always get the message:
    rEFIt - Booting Legacy OS
    Starting legacy loader
    Error: Not Found while loading legacy loader
    If I check the partitioning tables they are already in sync.

    Eighth, I boot the machine holding the 'alt' key and choose the windows drive but I always get the same error:
    BOOTMGR is missing
    press ctrl+alt+del

    Nineth, I run the Vista installer to repair windows several times. The first it seems to find a problem right away. On subsequent attempts I look at the diagnosis and repair details. At the end it says
    Root cause found:
    -------------------------
    Boot manager is missing or corrupt.
    Repair action: File repair
    Result: Completed successfully. Error code 0x0

    Tenth, I am stuck.

    Advice anyone? Anyone get rEFIt up on the new Macbook or Pros in normal graphic mode? Anyone get Windows installed? Any advice about the windows bootloader? I would think maybe it wouldn't need legacy mode since Vista SP1 x64 is supposedly EFI aware.
     
  2. kkrull thread starter macrumors regular

    kkrull

    Joined:
    Dec 19, 2006
    #2
    Ok, so I reinstalled Vista. Looks like the second time I might have more luck.

    rEFIt bootloader is still in text mode and will not load Vista, but holding the 'alt' key on reboot will load windows a couple of times.

    It would be nice if I had pulled the bootcamp drivers already. Without them I get the following undiscovered items in device manager:

    built-in iSight
    Coprocessor
    Ethernet Controller
    Network Controller
    SM Bus Controller

    Also, I can't drag anything because without a better mouse driver I can't click and drag. Audio doesn't appear to work by default.

    Any recommendations on the drivers? Can someone who got them installed tell me what devices they are?
     
  3. elppa macrumors 68040

    elppa

    Joined:
    Nov 26, 2003
    #3
    They're all on the Leopard Retail Disc, just pop it into you computer when you are running Windows. I imagine Apple puts them on the DVDs they ship with new computers as well.
     
  4. kkrull thread starter macrumors regular

    kkrull

    Joined:
    Dec 19, 2006
    #4
    Couldn't find them when I was looking fom the MacOS. There used to be a package inside the installer at the same level as the language folders.

    I see what you are saying - you can only see the files from Windows. I get it.
     
  5. kkrull thread starter macrumors regular

    kkrull

    Joined:
    Dec 19, 2006
    #5
    Ok, I did not survive the (Ubuntu) Linux install and am restarting most of the process over.

    While I am trying to survuve the Linux install I run across MacFuse and the corresponding NTFS-G code. Does anyone know of a MacFuse ext3 or ext2 implementation? Does anyone know how to put ext3 support from Tiger back into Leopard? Does anyone know why it was removed?

    In older tripleboot threads there is reference to this command which I have used before...
    diskutil resizeVolume disk0s2 65G Linux Ubuntu
    but of course Linux or ext or ext2 or ext3 doesn't appear and\or isn't supported any more.

    This time after the original nineth step of repairing the install it appears that the partition repairs itself and the install continues. Note to self - don't do much work on the Vista install until Linux is working this time.

    But at the end I get a message on the Vista installer "Windows could not update the computer's boot configuration. Installation cannot proceed."

    Bummer. I will try to reinstall Vista a couple more times before it is time to wipe the machine and start over.
     
  6. Stridder44 macrumors 68040

    Stridder44

    Joined:
    Mar 24, 2003
    Location:
    California
    #6
    Under Vista 64 the Leopard disc will auto-run, but the options it gives you does not include installing drivers for whatever reason (this might have changed on new Macs). Just right-click the Leopard DVD in My Computer -> goto Explore -> Boot Camp -> Boot Camp.exe. Of course, after installing and restarting, run Apple Software Update to get Boot Camp 2.1.
     
  7. kkrull thread starter macrumors regular

    kkrull

    Joined:
    Dec 19, 2006
    #7
    Any Linux experts out there?

    Ok, I cannot get Linux loaded and I have tried several different versions and ways. I think I have a bootloader issue. Whether I load GRUB or LILO from Ubuntu 8.04 or 8.08 beta, I always get a partition that can't be accessed by rEFIt (only the command line is working for now) or by holding down the 'alt' key. The installation completes, but I can't get it loaded.

    My windows partition won't load from rEFIt 0.11 but it does load from pressing the 'alt' key. The linux partition doesn't even show up. Here is what gptsync.efi from rEFIt shows...

    GPT partition table
    # Type
    1 EFI System (FAT)
    2 Mac OS X HFS+
    3 EFI System (FAT)
    4 Basic Data

    Current MBR partition table
    # Type
    1 EE EFI Protective
    2 AF Mac OS X HFS+
    3 83 Linux
    4 07 NTFS/HPFS

    I suspect that GPT status (as EFI System) is keeping the mac bootloader from appearing. Not sure how to change that.

    I am thinking for next steps
    1. to try eLILO from a Ubuntu live CD.
    2. to find a way to change the GPT status from EFI
    3. to try and move rEFIt to the EFI partition from the MacOS partition

    Any other hot ideas?
     

Share This Page