Visual Voicemail help

Discussion in 'iPhone Tips, Help and Troubleshooting' started by stbrown, Oct 13, 2011.

  1. stbrown macrumors newbie

    Joined:
    Jul 17, 2010
    #1
    Hi

    I upgraded to IOS 5 yesterday and I went to my voicemail and its giving me an error saying Could not authorize access. I had this error before during one of the 4.x upgrades but I am not sure how I solved it.

    So far I have tried resetting network settings, reseting my voicemail password and also restoring my phone. The same issue keeps on happening. Even when I go to the phone settings and input my pass code it gives the same error.

    My phone account still shows having visual voicemail on it and I havent changed anything on my account for a year.

    Im using a factory unlocked iPhone 4 purchased from Apple Canada and the carrier I'm using is Telus.

    One thing I did notice which is probably the cause of the issue, is that if press and hold 1 (to dial voicemail) it looks like its calling an AT&T access number instead of Telus

    Has anyone had this issue or have any ideas on how I can fix it?
     
  2. Gazamb macrumors newbie

    Joined:
    Oct 13, 2011
    #2
    Visual voicemail stopped after ios5.

    Yes I stopped getting visual voicemail after updating to ios5. I'm using a 3GS and never had this problem on any updates before.
     
  3. Stephaneezy, Oct 14, 2011
    Last edited: Oct 14, 2011

    Stephaneezy macrumors newbie

    Joined:
    Oct 14, 2011
    #3
    Hey! I had the exact same problem. I have an iPhone 4 GSM for AT&T and I updated my phone to iOS 5 today, I clicked on my voicemail screen and all it did was dial out to my regular voicemail.

    What I actually did was let it dial out to the voicemail just as if you were prompting to set it up for the first time, I entered my voicemail pw, and then re-set up my greeting. And after that, I waited for about 5 minutes and reopened the phone app to see if my visual voicemail came back and IT DID.

    Your best luck if that doesn't work is to probably have to redownload and reupdate your phone again.

    I'd just try that before actually redownloading the update on your phone..cause I don't know about you but it took mine about 45 minutes to update to iOS 5, I know you don't want to wait that long. Hope this helped!
     
  4. stbrown thread starter macrumors newbie

    Joined:
    Jul 17, 2010
    #4
    Resolved

    Issue is resolved now.

    I had to contact Telus technical support and they had to reset my voicemail connection on the back end. They say they have seen it happen to some customers when they upgrade to new versions of IOS
     
  5. extraextra macrumors 68000

    extraextra

    Joined:
    Jun 29, 2006
    Location:
    California
    #5
    Mine isn't working either... dunno if I should call AT&T or just wait for Apple to push out an update. Don't really want to reinstall iOS 5!

    edit: Typed in my password and it started working.
     

Share This Page