Visual Voicemail not working on Verizon iPhone 5

acousticbiker

macrumors 6502
Original poster
Jun 28, 2008
480
10
I have voicemails when I dial *86, but they don't appear in VVM. I set up my VM password through the VVM tab in the Phone app, but when I try to record a custom greeting I get a popup error that says 'Voicemail unavailable. Unable to connect. Try again later'

Has anyone else had this problem? Any fixes? I'm waiting to hear back from Verizon second tier support but thought I'd tap this group in the meantime.
 

boxermansr

macrumors 6502a
Feb 11, 2011
593
167
El Paso, TX
try to reset your voicemail password on verizons website, not sure offhand what section its under, but maybe that will help.
 

JCrew7384

macrumors newbie
Feb 24, 2009
5
0
I ported my number from ATT to Verizon with the new iPhone 5.

Visual Voicemail keeps asking me to set it up with a password. Then it says unauthorized. I spent an hour on the phone with Verizon support. They said I had to wipe my phone and set it up as a new phone.

I backed up, set up as new, went to Voicemail. It called my voicemail. I set up the account, and left a test voicemail. Visual Voicemail worked.

Then I restored back to my iPhone backup, getting all my data, apps, and contacts back, and the Visual Voicemail doesn't think it is setup anymore.

What gives??? Is this an Apple or Verizon issue? It works on a "new" setup phone, not a restored one???
 

acousticbiker

macrumors 6502
Original poster
Jun 28, 2008
480
10
try to reset your voicemail password on verizons website, not sure offhand what section its under, but maybe that will help.
Hadn't thought of that...but I just tried and it didn't work

----------

I ported my number from ATT to Verizon with the new iPhone 5.

Visual Voicemail keeps asking me to set it up with a password. Then it says unauthorized. I spent an hour on the phone with Verizon support. They said I had to wipe my phone and set it up as a new phone.

I backed up, set up as new, went to Voicemail. It called my voicemail. I set up the account, and left a test voicemail. Visual Voicemail worked.

Then I restored back to my iPhone backup, getting all my data, apps, and contacts back, and the Visual Voicemail doesn't think it is setup anymore.

What gives??? Is this an Apple or Verizon issue? It works on a "new" setup phone, not a restored one???
My phone is also restored from a previous iPhone with a ported number. Sounds like a bug - wonder if this has been an issue with previous iPhones (I had previously always restored from an iPhone that was with the same carrier until this time around). I really hope I don't need to set up as a new phone...
 

JCrew7384

macrumors newbie
Feb 24, 2009
5
0
Also not my issue. If I dial *86 it works fine. But when I click voicemail in the Phone app, it tries to get me to setup a password and choose a greeting, then can't figure out how to connect and fails.

Weird that on a "new" setup, the voicemail works just fine, but not with a restore which originally came from an AT&T iPhone 4...
 

Arbagel

macrumors newbie
Sep 28, 2012
2
0
Onavo

I found a solution in a blog. You may have an app that is interfering. For me it was Onavo extend. Delete the app and the profile (under Settings, profile, Onavo, delete)

Turn phone off and on and voila, works again.
 

JCrew7384

macrumors newbie
Feb 24, 2009
5
0
How did you determine which app was interferring...

After long talks with Apple and Verizon, they both wanted me just to setup as new. I tried backing up to iCloud (4 hours), then restoring with the iCloud backup (instead of the computer backup), and all seems to be working now...

Go figure. So far so good, but still restoring my stuff. Taking forever.
 

ezekel

macrumors regular
Jun 4, 2004
112
0
Royal Oak
do you have google voice installed? I noticed that I got two voicemails today that were sent to me as texts since I had voice setup on my android phone to do that.

I removed it and now need to test it.

edit: it was in fact google voice. I now have VVM
 
Last edited:

ffohwx

macrumors member
May 7, 2010
52
2
Fairfield, Ohio
Same problem, but different cause I think. Visual VM was not working for me. I left myself a couple of voicemails. Finally it popped up asking me for my VM password. Now it works. I had read this solution elsewhere (don't remember where). I did not port my number though. I was and am still on AT&T.
 

acousticbiker

macrumors 6502
Original poster
Jun 28, 2008
480
10
I found a solution in a blog. You may have an app that is interfering. For me it was Onavo extend. Delete the app and the profile (under Settings, profile, Onavo, delete)

Turn phone off and on and voila, works again.
Problem solved - huge thanks!
 

DSHoisington

macrumors newbie
Oct 10, 2012
3
0
I had Onavo too. Felt so stupid when I saw the profile. Thought I would check it, and sure enough. Onavo Extend was the problem.
 

richmds

macrumors regular
Sep 30, 2012
171
0
Something to try if its still not working. Have the carrier reset voicemail. Find out what the default pin is for voicemail dont change it. Go to VVM and enter the same pin.
 

DLRrules

macrumors newbie
Sep 13, 2013
1
0
do you have google voice installed? I noticed that I got two voicemails today that were sent to me as texts since I had voice setup on my android phone to do that.

I removed it and now need to test it.

edit: it was in fact google voice. I now have VVM
This was 100% my issue and the exact same thing solved it!!! REMOVE Google voice, Voicemail works!!! :)))