VLC... no more sound :-(

Discussion in 'Mac Apps and Mac App Store' started by coolmatt, Oct 6, 2012.

  1. coolmatt macrumors newbie

    Joined:
    Oct 6, 2012
    #1
    My config : iMac 2007 / Snow Leopard

    Hi folks,

    Hope someone can point me to the right direction...

    VLC is by far the best video player and I used it for many years... but something happened and I can't figure out what. The fact is, VLC does not output ANY sound.
    The last thing I remember was trying the game Walking Dead. It crashed the first time but then worked fine. Later, I wanted to watch a video... and the (real) nightmare began ;-)

    I tried a few things :
    - installed latest VLC version / no luck
    - reinstalled an older VLC version / no luck
    - declared VLC to run in 32bits mode (found this trick on a forum) / no luck
    - reinstalled latest version of Perian (but I doubt Perian is involved) / no luck

    I don't know what to do. It seems like the crash of the game has corrupted something, a shared library or so. My VLC acts like a zombie :-(

    Help me please...

    matt.
     
  2. justperry macrumors 604

    justperry

    Joined:
    Aug 10, 2007
    Location:
    In the core of a black hole.
    #2
    Do you have any sound on your system?

    Do you have any sound on different Applications?

    Try to log into a different user, open VLC again, and play a movie, do you hear any sound now, if yes there is/are corrupted files/settings in your normal account.
     
  3. coolmatt thread starter macrumors newbie

    Joined:
    Oct 6, 2012
    #3
    Thank you so much for your answer

    1/ I do have sound on other applications
    2/ I tried with a different account and VLC works well !

    So, any clue to reset/adjust the corrupted files/settings in my account ?

    Regards,
    matt.
     
  4. justperry macrumors 604

    justperry

    Joined:
    Aug 10, 2007
    Location:
    In the core of a black hole.
    #4
    I am almost of to bed so a quick one, will report more tomorrow.

    It's almost sure it is in your preferences files, what you can try is to make a new folder, move all of your preferences there and logout and in again, if it works now there is one which is corrupt.

    You can always put those back so no worries.

    But if the problem was solved by moving all of them out then you should move 50% back and logout/in again, if the problem is back it's in the 50%.

    I will be back tomorrow.
     
  5. coolmatt thread starter macrumors newbie

    Joined:
    Oct 6, 2012
    #5
    Solved ! You were right. Something went wrong in the preferences files. Thanks to you. Hope you had a good night. Mine will start with a movie ;-)

    Best regards.
     
  6. justperry macrumors 604

    justperry

    Joined:
    Aug 10, 2007
    Location:
    In the core of a black hole.
    #6
    Good.

    Actually, just after shutting down my laptop I was in bed and thought I should have said to look if it was your VLC preferences.
    Easier than looking for 1 of the many inside the preference folder.

    Cheers
     

Share This Page