VLC on a late 2013 MBA

shandyman

Suspended
Original poster
Apr 24, 2010
6,472
384
Dublin, Ireland
I'm having problems with MKV's pausing themselves for up to 30 seconds then resuming after the screen goes grey for a few frames. This tends to happen a minimum of 2 times during playback, usually more.

I've tried turning on hardware acceleration, tried the skip loop thing, the threads to 4. Nothing helps. Since, on the whole, macbook airs are the same setup across the board, has anyone else had this problem? Know how to sort it? It's beyond frustrating. I don't want to have to convert them all the time in handbrake to mp4 either.
 

Dweez

macrumors 65816
Jun 13, 2011
1,246
9
Down by the river
I use VLC 2.1.3 for MKVs created with MakeMKV 1.8.9 on my mid 2013 MBA with zero issues, using all out of the box settings for both MakeMKV and VLC.

Are you seeing any other issues with your MBA? Have you tried any other video players?
 

shandyman

Suspended
Original poster
Apr 24, 2010
6,472
384
Dublin, Ireland
I have no issues with mp4 videos. Had a similar problem with another mkv player. The MKV's I get are downloaded and no one else has problems. They seem to work fine on a windows PC running VLC, pretty much. Only other issue I've had with the MBA is that twice since I got it in January the fans kicked in really high and it became a little unresponsive until I reset it using the power button. No idea why that happened but, as I said, only happened twice in the whole time I've had it. (Bought early January this year). Don't think it's connected.
 

Cooee!

macrumors member
Feb 16, 2014
84
30
I have the same macbook and I play mkv files with vlc and my only problem is losing sound when rewinding sometimes. No problems even playing mkv files like my 24 min video which is more than 1 GB in size.
 

tbobmccoy

macrumors 6502a
Jul 24, 2007
917
158
Austin, TX
I had this problem on my 2011 MBA. Your solution of converting to mp4 is what I did :)

Alternatively, you could use Plex instead of VLC for playback.
 

kage207

macrumors 6502a
Jul 23, 2008
972
8
I had this problem on my 2011 MBA. Your solution of converting to mp4 is what I did :)

Alternatively, you could use Plex instead of VLC for playback.
A vote for Plex here. I don't use VLC.

Are the movies all on a local drive?