VLC Player Subtitles

Discussion in 'Mac Basics and Help' started by madcowd211, Dec 1, 2007.

  1. madcowd211 macrumors newbie

    Joined:
    Nov 30, 2007
    #1
    After I connected my external HD and started a movie with Korean subtitles, the subtitles were broken.

    Movie was in AVI format and subtitles were in SMI format.
    Any solutions?
    Thanks!
     
  2. unknown.exe macrumors member

    unknown.exe

    Joined:
    Sep 22, 2007
    Location:
    Somewhere on Earth
    #2
    VLC is the best vid-player out ther. But to solve your problem, it seems that either the movie is bad, or.... well the movie is bad. I guess this is from limewire or bitorrent. If this doesn't occur on other monitors, then it is the monitor's fault.:apple:
     
  3. madcowd211 thread starter macrumors newbie

    Joined:
    Nov 30, 2007
    #3
    That can't be it because it worked on my PC T_T
     
  4. unknown.exe macrumors member

    unknown.exe

    Joined:
    Sep 22, 2007
    Location:
    Somewhere on Earth
    #4
    VLC is the most reliable video player... I had Borat the movie that I played on VLC, and their is a part wher it freezes for about a second. A few days later I played it again and the freeze was in a different place. If I were you I would just try playing it w/ some other player, and if the problem persists then there is sumptin wrong w/ the video.
     
  5. Alistair.connor macrumors newbie

    Joined:
    May 23, 2008
    #5
    This is possible.

    About 6 months ago, I had the same problem and eventually figured it out so I know that it's possible to read the korean subtitles using .smi properly. However, recently I used a cache cleaner and accidentally deleted something that I needed to watch with korean subtitles. I am now kicking myself for not taking screengrabs of the eventual settings!!!!! I remember it had something to do with the korean fonts themselves and more specifically, the yoncon.ttf font but I cannot remember anything else, if you know please help!!!
     
  6. Alistair.connor macrumors newbie

    Joined:
    May 23, 2008
    #6
    Got it! korean subtitles working on VLC

    After playing around for a bit, this is what I needed to do:
    #1 Preferences>video>subtitles/OSD First, I unchecked Autodetect subtitle files. Second, I browsed to library>fonts>yoncon.ttf (that's the korean font file I think I downloaded it myself a while ago..not sure where from though)
    #2 Preferences>video>subtitles/OSD>>Text renderer, again, I browsed to the same font file
    #3 Preferences>Input/Codecs>Other codecs >>Subtitles>>>Subtitles text encoding>>>>CP949
    #4 When opening the .avi file, VLC>File>>Open File>>>browse for your .avi file
    #5 When opening the subtitle file, VLC>File>>Open File>>>check Load Subtitles File>>>>Settings>>>>>Browse for your subtitle file (mine are usually .smi)>>>>>>Subtitles encoding>>>>>>Cp949
    If you're in need of this info and having difficulties with my instructions, send me a pvt message and I will send you my screengrabs. Good luck!!
     
  7. digital packrat macrumors newbie

    Joined:
    Nov 12, 2009
    #7
    Any idea where this font? It's not in my font library.
     
  8. SaaGua macrumors member

    Joined:
    Apr 22, 2010
    #8
    If you can please post the screen grabs. I tired PM you but you have the option disabled.

    Thanks
     
  9. SavMBP15 macrumors 6502

    Joined:
    Mar 26, 2010
    #9
    Bit of a necro thread. I was looking and saw that this thread had only a few replies but like 18k views. Opened it up and saw it was from 2007.
     
  10. SaaGua macrumors member

    Joined:
    Apr 22, 2010
    #10
    I tried searching everywhere for this, "yoncon.ttf" file. Nowhere to be found... :mad:
     
  11. kimbab0589 macrumors newbie

    Joined:
    Jul 22, 2010
    #11
    ha! i think i figured it out!

    okay, instead of looking for "yoncon.ttf" look for "AppleGothic.ttf"
    this font file can read Korean.
    basically follow all the same directions except for the "yoncon.tff" part and you're solid~~~~ :D
    let me know if you're still having problems!
     
  12. SaaGua macrumors member

    Joined:
    Apr 22, 2010
  13. zakool21 macrumors newbie

    Joined:
    Aug 15, 2010
    #14
    You can use any other Korean font you have installed on your computer, it seems. I signed up to add this bit:

    Go to your Font Book.app and find which Korean fonts you have installed. I have three: HeadLineA, AppleGothic, and AppleMyungjo. I find that HeadLineA is most readable.

    All of the other instructions provided to make this work happen to work perfectly, and I give great kudos to the person who provided those instructions. Thanks!
     

Share This Page