VLC - Remove 'Recently Played'

Discussion in 'Mac Apps and Mac App Store' started by blairh, Nov 22, 2015.

  1. blairh macrumors 68030

    blairh

    Joined:
    Dec 11, 2007
    #1
    Hello. When I quit VLC from the dock it shows a list of recently played videos with VLC. I see no option to disable this feature for the Mac version of VLC. Apparently this option does exist with VLC on Windows.

    Does anybody have a solution? Thanks.
     
  2. DaakuMaujii macrumors member

    DaakuMaujii

    Joined:
    Oct 25, 2015
    #2
    VLC: Preferences -> Show all -> Interfaces -> Main interfaces -> macosx -> Behaviour -> Keep Recent Items checkbox?

    Otherwise, Mac OS X: System Preferences -> General -> Recent items: None; but that will affect the whole system.
     
  3. blairh thread starter macrumors 68030

    blairh

    Joined:
    Dec 11, 2007
    #3
  4. DaakuMaujii macrumors member

    DaakuMaujii

    Joined:
    Oct 25, 2015
    #4
    Then it's probably a bug in VLC. I never bother with recent items, so I use the system-wide settings from Mac OS X's System Preferences.

    The method provided in the link you posted should be safe to use. Just make sure you delete the correct file, otherwise you might lose your preferences for VLC or other application.
     
  5. Fuith macrumors member

    Joined:
    May 5, 2011
    Location:
    Tralee, Co. Kerry, Ireland
    #5
    File -> Open Recent -> Clear Menu seems to work ;)
     
  6. DaakuMaujii macrumors member

    DaakuMaujii

    Joined:
    Oct 25, 2015
    #6
    That is probably a lot easier. Especially if you only occasionally need to clear recent items.

    If you want VLC to never remember the last played items but would like other application to remember recent items, you could try to make the 'org.videolan.vlc.LSSharedFileList.plist' file read-only, or remove it and recreate it as a symbolic link to /dev/null.
     
  7. Max(IT) Suspended

    Max(IT)

    Joined:
    Dec 8, 2009
    Location:
    Italy
    #7
    Always used that...
     
  8. hmachina macrumors newbie

    hmachina

    Joined:
    Nov 20, 2016
    #8
    This works for me:

    1. File -> Open Recent -> Clear Menu
    2. Quit VLC
    3. Open Terminal and paste the next commands...

    defaults write org.videolan.vlc NSRecentDocumentsLimit 0
    defaults delete org.videolan.vlc.LSSharedFileList RecentDocuments
    defaults write org.videolan.vlc.LSSharedFileList RecentDocuments -dict-add MaxAmount 0
     
  9. MDJCM macrumors regular

    MDJCM

    Joined:
    Sep 12, 2009
    Location:
    UK, South
    #9
    I found it!

    Go to VLC -> Preferences -> Interface tab -> Click the "Show All" button on the bottom left of the window.

    Go to Interface -> Main Interfaces -> macosx -> "Keep recent items" checkbox

    [​IMG]
     
  10. jwtreadwell macrumors newbie

    jwtreadwell

    Joined:
    Aug 14, 2017
    #10

    This is the ONLY thing that I tried that actually worked--thanks! :)
     
  11. maculateConception macrumors regular

    maculateConception

    Joined:
    May 28, 2017
    Location:
    Die Bundesstaat Kalifornien
    #11
    Y'all need to stop watching pornography on a shared computer :D
     

Share This Page