VLC & Skype won't open?

Discussion in 'OS X Mountain Lion (10.8)' started by dannster, Nov 27, 2012.

  1. dannster macrumors regular


    Oct 10, 2008
    London, UK
    Hi all,

    I'm trying to open VLC and Skype in Mountain Lion (10.8.2), on my MacBook Air and they won't open! They just bounce in the dock and after a couple of minutes the fan kicks in, forcing me force close them both.

    Does any one have any ideas if this is a known issue and how to fix it?

    Many thanks! :)
  2. MRiOS macrumors regular

    Jun 2, 2010
    have you tried deleting the apps and re-downloading them. (just deleting the apps out of the applications folder and then copying them back from the downloaded disc images won't delete your settings, those are in a different folder.)
  3. demo092 macrumors newbie

    Jan 26, 2013
    Here you go ;)

    This is a very effective solution that I have tried myself. It's quoted from the VLC forums and written by the user "Regula":

    "I have had this problem during 2 periods with VLC and Skype. First time I just right-clicked on the app and went to "Show Package Contents" > "Contents" > "MacOS" > "VLC" or "Skype" and it fired up right away. I endured quite a while but at last reinstalled OSX because of a HDD change, and the problem was no more. But now after some week it came back! Searched a lot for different solutions but none of them worked. Came around a post somewhere that Refog may be the issue, I threw it into the Trash but the problem did not go away. In frustration I thought of terminating strange processes, because it worked tremendously to fire it up the tediuos way. I just skimmed through the list and got stuck at the "smoke"-process, remembering that it maybe was something fishy about it. Just terminating it did not solve the problem, then when i examined it and deleted the related files it worked!

    This is how i did it:

    Open Applications > Utilities > "Activity Monitor". Search for a process called "smoke". If there is one it could be it. It comes from the Refog application. What you have to do is:
    - Remove all instances of refog from your computer, search for refog in Spotlight. But there are also hidden instances of refog/smoke.
    - Select "smoke" in the Activity Monitor and click "Inspect", then press the "Open Files and Ports"-tab and a list of paths comes up. There look for paths containing "/.Refog/" and "/.smoke/". These folders are hidden.
    - To show hidden folders type:
    defaults write com.apple.Finder AppleShowAllFiles TRUE
    in Terminal and then
    killall Finder
    for the changes to apply. Then go find the folders and delete them. You should also kill the "smoke" process. Now also uninstall all the apps behaving suspicious.
    - You may also "Repair Disk Permissions", I didn't!
    - Now empty your Trash, reboot, install VLC, Skype or whatever troublesome app (Eclipse was also hassling for me) .
    - Now hopefully they work!

    Wish you best of luck!""

Share This Page